Info Rover on a boat

I have mounted the pixhawn board on a boat. I uploaded the rover firmware 3.2.1. In Manual it works perfectly but in mode Guides it seems that it turns the other way around. In steering mode everything is ok. I tried in mission planner in the radio calibration to reverse both the rool and the throttle but without success. Attachment my configuration file. GPS ok and Waypoint ok. Can you help me?

definitivo.param (11.1 KB)

Hi Andrea,

Sure, I’ll have a look at the param file. Also any chance you could attach a dataflash file (aka .bin file)?


The confusion probably comes from the difference between reversing the inputs vs reversing the outputs.
I suspect the reversing problem can be fixed by changing these two parameters:

  • set RC1_REVERSED to 0
  • set SERVO1_REVERSED to 1

More generally, the input reversing parameters (RCx_REVERSED) can be used to make the green bars on the radio calibration screen move in the same direction as the physical sticks on the transmitter (except for the Pitch channel which should move in the wrong direction). Personally I don’t ever use the RCx_REVERSED parameters, instead i change the reversed settings in the transmitter itself.

The output reversing parameters (SERVOx_REVERSED) are used to deal with the motors spinning in the wrong direction.

One other small thing is CRUISE_SPEED parameter is 100m/s! This probably should be lower. The wiki for speed tuning is here including details on how to capture the cruise-speed and cruise-throttle values using the ch7 auxiliar switch.

Hope this helps.

Thanks rmackay9 for the precious information.
Today I do some tests then I’ll let you know.
If I can also attach the dataflash file.
I could not understand the difference between RCx_REVERSED and SERVOx_REVERSED.
Thanks again.

today I have done some tests but without result. I have inverted Servo1 and Servo3 and it would seem that in Auto mode it works fine but so in Manual it has problems. It’s normal ?


RCx_REVERSED controls how the input from the transmitter is interpreted. I.e. full left stick input results in high PWM coming into the flight controller or low PWM?
SERVOx_REVERSED controls the direction of the output to the motors/servos. i.e. if we want the left wheel to spin forward, should we send a high PWM or low PWM?

If auto mode is working then it’s likely that the SERVOx_REVERSED parameters are now correct. If manual mode isn’t working then it’s probably the RCx_REVERSED that now needs fixing.

I think it would be good to ensure that the most recent version of mission planner is installed (try going to Help and push “Check for Updates”) then go to the Initial Setup >> Mandatory Hardware >> Radio Calibration screen and uncheck the “reverse” checkboxes (or set RC1_REVERSED = 0, RC3_REVERSED = 3) then make sure the green lines for throttle and roll move in the same direction as the physical sticks. If they don’t, modify the reversed setting in the transmitter.

OK I will still do some tests. Another question. Do I have to calibrate the accelerometer? Is it normal that the icon rover on the map is not stable on MP? Thanks.

Yes, the accelerometers will need to be calibrated (covered in this section of the wiki).

the icon may move around but it’s most likely because the vehicle is indoors and the GPS reception is not good. With a log we can be sure but it’s the likely cause of this type of report.

hello I did several tests and I should have found the optimal configuration.I will have encountered a strange problem.The steering works in the right direction only if the throttle is at maximum, otherwise with the throttle in neutral position the steering works in reverse. Why ? Thank you.

Hi Andrea,

I wrote this motor test wiki page just recently to help with exactly these kinds of problems.

Can you give it a try?


Hi Randy,
I tried the Testing Motor direction. Clicking on Test Motor C starts the right engine of my boat. With Test Motor D the left engine starts. I do not know if it is correct but also by changing the SERVOx_REVERSED values, the two engines behave in exactly the same way.
Thanks for the help you are giving me.

I am attaching updated parameters.parametri 322.param (11.2 KB)

Today I realized I had connected the rc1 to the right engine and rc3 to the left engine. From the manual of the rover is the opposite, maybe this is my problem. Can I reverse the two values 73 and 74 on SERVOx_FUNTION? Thank you.

1 Like


Yes, swapping the SERVO1_FUNCTION and SERVO3_FUNCTION parameter values should work.

As a side note, it’s great how quickly that wiki page and MP test page has paid off. I’m sure this will help other users too.

Hi Randy,
I have to thank you now everything works correctly. The only thing is that I would like my boat to make a way more direct to wayponits. I attach a photo where you see what I mean.
Is there any option to improve it all?

1 Like


yes, it should be possible to make it move in straighter lines. Some things that could help:

  1. tuning. If you have a dataflash log I can have a peek and maybe give some advice.
  2. the latest development version which hasn’t been released yet has a bug fix to how the line is calculated between waypoints. If you want to try this version, go to the mission planner’s Install Firmware screen and press Ctrl-Q. The name below the rover icon should change to “ArduRover V3.3.0-dev”. So you could try this and see if it helps at all. The fix is small so I don’t think it will solve everything.
  3. I am working on some code changes in a branch here that will help. It’s still a work in progress though so I’d like to work on it a bit more before getting people to try it out.

Hi Randy,
I installed the version “ArduRover V3.3.0-dev”. It seems to be going better. Attached to the logs file. Let me know if I can change something.
Thank you for your time.