Incorrect time -How to adjust time stamp Pixhawk MP

I’ve searched around and found only incomplete information about time obtained from your GPS.
So I’m using the latest Mission planner, connected to an original Pixhawk (3.5) via USB.
Connected on port 10, Open MavLink inspector, Expand Comp 1-System Time
When I can see the date and time is wrong, I also see Unix Epoch notation that is incorrect as well…(yes I have 3D GPS lock)
I do Not see any options below that for Ground station parameters…

So, How do I go about setting the correct time, is there time zone to also set?

It’s UTC, as is all aviation.

Sure, so my off set would be -5 hours but day nor minutes are the same as my ground station NTP time…

So are we saying there is No time adjustment, whatever the GPS brings is what you got?