In Loiter Turn, the CW selection disappears with Read WP

I set up a simple mission today with 3 loiter turns in it, and set CW=1, and they all executed OK. I then plugged my APM2.6 controller into Mission Planner and read out the mission, and the “CW=1” was now set to 0. I had saved the mission on my desktop, so I down loaded it to the APM again, and behold! The CW=1 was indeed a “1” again. Apparently just READING the mission data from the APM erases this bit!
Details: APM 2.6
Software 3.1.5
Mission Planner 1.3.5 Build 1.1.5260.33055

Is this a bug or am I the problem?
Best regards, Jim

Today I tried a variation on the 3-loiter-turn mission. I wrote a mission that asked for a CW turn at WP1, a CCW turn at WP2, and a CW turn at WP3. I got three clockwise waypoints when I flew the mission. When I returned home I reviewed the mission that was stored on my desktop, and it was CW, CCW, and CW, just like I wrote it. Either my APM 2.6 with firmware 3.1.5 doesn’t obey the CW/CCW bit, or it didn’t get written to the APM properly. Or maybe I am doing something wrong…!

Maybe I have figured out why my quad only does clockwise loiter turns. Maybe it’s a stuck bit in memory.
I say this because no matter what direction, CW or CCW, I ask for in the mission, the quad only does CW. And when I do “Read WP” to retrieve the mission from the copter, the direction bit is always 0, never 1.

But this explanation only holds water if the direction of rotation is defined as “looking up from under the copter”, since the direction bit always seems to be 0, and 0 is defined as “clockwise”.

Does anyone know what the definition of CW and CCW is, whether it’s observed from above or below the copter?

And is there a memory-check diagnostic?

I just realized that there is a serious flaw in my “stuck bit” theory (in the paragraph above). If I am executing 3 loiter turns, and all three of them go clockwise when they should go CCW, then 3 bits, not just 1, would have to be “stuck”. That’s not very likely…
So I still don’t know what causes the “CW=1” bit to get reset in the APM, or when it happens…

Any suggestions, folks?

Hi Jim,

Please tell what is your copter firmware (quad, Y6, hexa, etc) and please post the mission file and a log file.

Here you can find how to donwload the logs: … n-planner/

This information is necessary for the supporters to help you with your problem.

I think I have added the log file to this reply, but I don’t know if I have added the mission-definition file. I can send it via e-mail, I bet…

I have tried attaching the mission-definition file in three forms:
.txt (the native format)
and all three have been rejected. What format is allowed?

I am using a fairly modern hp laptop with WIN7, if that helps…

Today I thought maybe I had figured out why I cannot get my quad to do a counter-clockwise turn. I was wrong!

After browsing around the forum pages for quite a while, I found an entry where someone defined “clockwise” in a loiter turn as being either a 1or a 0 in position P3, with CCW being a -1. I then wrote a brief mission with a couple of -1 turns in it, and flew it this morning. I got all CW turns. Shucks…

Anybody else having trouble getting their quad to do a CCW turn?

I am using 3.1.5 code and MP 1.3.7…

I have the same problem. There is no way to do a loiter-turn in ccw. I think its a bug.