Impossible to connect Cube to MP by USB

I’m trying to connect my cube to Mission planner.
I can the COM Port on my computer but Mavlink block and failed when I launch the connection.
I follow this tuto
with a baudrate at 115200.
The cube is only linked to the GPS and the buzzer.
I make the connection with the micro USB on the side . I’ve tried multiple USB cable.
Is there a tips to debug the problem ?


Un-install mission Planner and reinstall it to fix the device drivers installation.

I’ve tried it
And I’ve the same error all the time. I’ve change my COM from 23 to 2

I work on W10 pro 1909(Last version update)
When I remove the driver unplug the cube and plug it back, the cube appears directly as COM23 with a bus name “CubeBlack-BL” .
The driver install pilots for
Arduino LLC
Hex Technology Limited
3D Robotics
Laser Navigation
And after install the peripheral name change to
I never see Cube Orange.

right click it, click uninstall, and make sure you tick remove driver as well.
then replug it in and see what it does

Have you installed fw on cube?

I’ve made made the right-click uninstall.
When you install the driver you can remove it too.
After reboot and reinstall
I can’t install the firmware because I can’t connect the cube.

I’ve remove manually all the driver installer by the driver application.
Plug unplug
Reinstall driver.
It still the same :poop:
I don’t know what to do.
If I try to open this serial port with another application it crash .
Is someone have a trick because it is the third days at the first step.

I Had the same problem, asked a lot of suggestions and philip said maybe was a faulty Cube. I ended up sending back to getfpv!!
Didn’t work at all.

1 Like

it sounds like a driver issue to me.
try this file
this will hopefully clean all the old drivers out, then install the new ones

I’ve installed and uninstalled this driver about ten times .
I’ve tried to removed it manually .
Nothing change.
It is always “ProfiCNC CUBE F4-FMU”.

I’ve tried on other computer . The result is the same.
Is there some logs somewhere to see something, or test IHM for the cube ?
The problem come from the cube. The Serial COM created is a fake because I can’t open the COM with putty.
Is there some other drivers ?
I use W10 like most of people .
When I connect the cube the light is green during half second and became orange the right led blink during 3 sec and that the led stay orange and ON.

if it says “ProfiCNC CUBE F4-FMU”
then the driver is not being uninstalled.
the MSI i linked to has a drivercleaner.exe in it, that trys to remove all older drivers. it needs to be run as admin to do this

When I launch the msi in admin mode it jump directly at the end of the installer.
it is a shame to run the msi in admin mode , you have to add this key in the register
“%SystemRoot%\System32\msiexec.exe” /a “%1” %*

the problem is the same , I can see all the driver package still installed on my computer even if I do a remove in the driver installer in normal mode.

I try IObit uninstaller to remove correctly the driver, reboot and plug the cube.
I never get the orange name.
At first step there is something in the windows driver or in the VID PID of the cube .

Without driver, the cube is recognized as CubeBlack

compatible cdc and AT command

Yep that’s the bootloader. Install a firmware on it

Is it possible that the cub is blocked in bootload mode ?

The last packet the cube send in USB is
So I try to connect in 38400 but same problem : “Mavlink Connecting” during 3 min and the error

Don’t click connect. Select the correct port in Missionplanner, then flash a firmware to it, then reboot and try connecting

Ok, the upload solution works .
Thanks you:heart_eyes: