Servers by jDrones

Immense Voltage Drop on TakeOff according to Mission Planner

(Bharath Kumar) #1

Greetings

Recently I have been facing a very weird issue with my drone. Voltage sensing is completely off. As soon as I takeoff my battery voltage drops to values like 6V from 16V (verified from logs). I have calibrated my voltage and current sensors from the battery monitor calibration settings in mission planner :: initial setup>optional hardware>battery monitor. But still when voltage drops there’s a significant difference compared to actual voltage (from cell meter). Hence I am not able to use the battery failsafe voltage. As soon as drone takes off failsafe is activated. Tried changing the power module. Still problem persists. Checked battery life by connecting an independent cell meter. Battery is ok. Any idea how to fix or why this is happening?

My setup:
f450 Quad
850 kV motor
40A Esc
10" props
Pixhawk Cube 2.1 Running arducopter 3.6.9
Brick Power Module which came inbox with Cube

Edit: The other power module i tried was from Radio Link

(RickyG) #2

I had an issue like that and it was the power to the flight controller dropping to the point where the voltage and current sense was failing.
Sounds stupid but it drove me to drink trying to figure it out. I found it by disconnecting all the peripherals and then suddenly the current and voltage sense was right. Not saying this is whats happening to you…just something I had experienced that sounded similar.

(Bharath Kumar) #3

Thank You for your input. I will test it out. How did you solve the issue?

(RickyG) #4

In my case I took all external devices that pulled power off the flight controller and switched them to a dedicated bec.
Once that was done the flight controller only had to worry about it’s self and all was good. Again not saying this is the problem your having but it sounds similar and well it was really strange.