iFlight Beast F7 55A V2 AIO Flight Controller

Morning all.
Need some help. I bought a Beast F7 AIO…I thought I was getting the H7…my bad. Can’t read after all these years.
Anyway with a little effort I got the bootloader upgraded and Arducopter installed.
But I get a config error, Baro not initializing. Drive can’t load type error. I did make sure I used the F7 firmware so I would assume it take into account that there is no barometer. But it doesn’t.

Any suggestions would be appreciated.

Did you use the v2 firmware? There is no baro on the v2

Hey Andy hope you and yours are well.
I never saw a V2 software
This is what I saw at the repository.


v2 is only in 4.2 so you will have to use the beta

where do I find beta firmware…I never live on the edge so no clue where that is


Ya I found that and tried via mission planner to upload the bootloader version per the wiki…Still get the errors this time it’s a new one. I uploaded using STM32Cube…that got the firmware up there but still no joy.
Just gives me fix problem then reboot.
Something about INS unable to initialize.

Specifically I used the STM32Cube app to up load the Arducopter Bootloader version of the Beast F7V2 Firmware. I can then connect with Mission planner but it starts yelling at me about the config error.
If I try to upload the firmware again using Mission planner it says it’s already there.

I even tried the heli firmware same message.
went back to Copter…same thing…no go

v2 has a different id, are you able to flash the hex file?

So to be clear you mean this hex

In the BEast F7 V2 Folder. Correct.

No. the one below it

Ya tried both with no joy.
Dave just told me there is no I2C on this board so I can’t connect an external Baro if I wanted to.
So basically this is of little use to me. I should have bought the H7 board…my bad.
Would be nice to get it working.

I have one - I’ll give it a try when I get a chance

Thanks Andy.
Not sure it’s of much use to me without I2C…

v2 has i2c, just no baro …

ok then I do need to get it to work then. I have a drotek baro in the drawer so if I can get this baby working I can put it to use. That said I have found no documentation that shows where the I2C port is and how to use it.

The F7 V2 has I2C or the H7 V2? F7 V2 Readme says no I2C, H7 V2 says is does with an Alt board config. Or I’m just confused which could be the case!

1 Like

I just loaded that file on mine with STM32CubeProgrammer - all worked fine. So either you have a different board or you are doing something wrong.

Mine has v2 printed on it

Note that there are two "v2"s. Mine is the BMI270 one, which is called v2.2 on the website. There is also an MPU6000 v2 which looks like it still has a baro in which case the old BeastF7 firmware should work.

Mine says V2 on it. I don’t know what BMI270 is or where to look for it.
There is something that sort of looks like a baro but there is no hole in it.

To flash it I did the following.
I pressed the Boot button on the board and plugged it into the pc.
I started STM32 and pressed connect.
I pressed open file and selected the hex files.
I pressed download. When done I disconnected.

Thats it.
IF mine is a V2.2…is it different firmware or the same.
Which is the old Beast F7 firmware.
This says MPU6000
this is what Mission planner says


That’s the MPU6000 version and looks like it has a baro, but I think it’s a different baro (DPS310) so we will have to do another hwdef for this version :frowning:

where is the baro. I see things sort of Baro like but no hole…at least none that I can see.
Also I guess I will wait on the new version. Exciting times lol.
I really appreciate your support Andy. Your my hero, well you and @dkemxr Dave