i2c port not working

I’m setting up my skywalker to fly mapping missions but have run into a snag. I cannot get my i2c port to recognize any device connected to it. I have latest firmware 3.30 and running mission planner.

Does anyone know if there is a bug in this current firmware? I’ve tried swapping cables, and directly connecting devices into the port instead of the splitter. I cut a cable open and tested the power output and am getting the proper 5v and 3.3 v on the correct wires so I cannot see where I am going wrong here. Any advice would be great, guys at 3drobotics tried to help out but were unable to find the problem either. I know its not working because I get no response on the airspeed, or LED external light. The compass calibration also indicates that my external gps compass is not connected, the pixhawk calibration works just fine on its own. This is the only port that I am having difficulties with, there is no broken pins etc.

Any help would greatly be appreciated. I am at the point of buying a new board if I can’t figure this out soon.

Try setting the full parameter list to the default values and then do a reboot.

Can you please send a dataflash log file and describe which devices were attached to the I2C at the time. I’ve not heard of this issue before in the ArduPilot software so I suspect you might have a physical board problem. Be careful removing those DF13 connectors - they can separate from the board very easily. We use a male USB connector and get the flat of it between the DF13 and its socket and slowly prise it out. This puts a downward pressure on the socket thus keeping it on the board and an upward pressure on the connector. Make sense?

Thanks, Grant.

Thank you! Resetting the permitters instantly made all I2C devices work. It would be nice to know what setting could turn off all of these sensors for future reference. Now time to fly :slight_smile:.