I "think" my tune is close

I’ve designed and built a few 1000mm quad with T-Motor MN605-320kv arm sets (Alpha ESC’s). MN2211 props.

I’ve spent the past couple of days working on my tune but really want this one to be as tight as possible.

What is the consensus on the MOT_THST_EXPO at .2 for Alphas at this point?

Can some of the tuner gurus take a look at my most recent results and provide feedback?

Log: 2-1/10/23 - Google Drive



The dynamic notch filter isn’t right. You have Throttle Mode configured but 0 for reference. The Freq, BW and attenuation don’t look right either.
Set these and make another hover flight:

And these
PSC_ACCZ_I (from the tuning guide 2X MOT_THST_HOVER)

I see you have Auto Tune aggression at .07. You don’t want that. The goal is Auto Tune at default (0.10). Too low of an agression can produce low PID’s with a mush feel.

But, not a bad start. I’ll let others address the T-motor ESC Expo, that advice has been all over the map.


I agree with everything @dkemxr said. And I’ll add that you’ve disabled some of the arming checks. You should be able to run ARMING_CHECK,1. If not, look for the reason why it’s stopping you.


Thanks! I’m heading to the field to run these tests shortly!

In case you haven’t run Magfit for the compass cal and compass motor compensation make a second flight with a lot of yaw action and some changes in thrust/current. Kill 2 birds with one stone today :grinning:

1 Like

I’ve run it and implemented already. Good call.

Excellent. I saw the Compass mot coefficients in there but wasn’t sure if you used the “cut your fingers off and blow paper all over the room” method or the right way :wink:

1 Like

Shouldn’t the reference be set to 0 for static? I don’t have ESC telemetry.

For static yes but you can use throttle reference dynamic notch which is what you have configured. No telemetry needed for that. You can use FFT* also but throttle can work very well.

*With all the hoopla these days about slow loops and such even on H7 processors throttle referenced may be a better choice. Although in the latest Beta release (today) that seems to be addressed.

1 Like

So INS_HNTCH_REF should be “1” I take it?

Some of those aren’t in play just yet (Rangefinder, camera, etc.).

No, set to MOT_THST_HOVER. At least for now.

Use the calculated MOT_THST_EXPO to suit your props, 0.76
There’s been reports of 0.4 working well with the integrated Motor/ESC combo too, so maybe you could start with 0.6 and see how that goes, then adjust up or down as required.
After changing this allow plenty of time in ALTHOLD hovering to ensure a new MOT_THST_HOVER is learned.

  • set too high you can see instability at low throttle
  • set too low you can see instability at high throttle

And everything the other guys said…

Definitely use these settings for the Harmonic Notch Filter to start with
The frequency might need adjustment but it will be close enough for now.

The trick with relying on FFT to get your data and settings → is the FFT_MINHZ value for anything larger than a old F450 frame. This needs to be about 30Hz. And maybe a few other FFT settings need adjustment too. FFT ends up being focused on one of the harmonics instead of the actual problem frequency. You can bet the frequency to target will be half of the frequency that FFT found, in this case.

Set FFT_ENABLE,0 for now and you can come back to it later if required.
If you’re going to have many varied payloads this can be useful, otherwise throttle based HNOTCH will be fine.

Adjust these a bit

I would definitely set
Seen lots of logs where people think they are good to go, but the GPS position is still wandering and it causes a tip over or worse. This should be the default for anything larger than a very small quad.
I’ve seen a big CF prop make a sizeable dent in a galvanized steel boat trailer, so imagine what it’s going to do to a meat bag when the copter thinks it’s got to go home to the Sea of Japan or somewhere random.
The effect of the Fence is, it doesnt allow you to arm in any mode until Home can be set. If it seems to be taking a long time that’s because the GPS position is still wandering. It’s best to just wait and use the time to think about the planned flight.
You can set
to limit the number of constellations and potentially improve the time to a good HDOP and 3D fix.
Also change GPS_GNSS_MODE2 to the same value.
Use the popup selection window in MissionPlanner (when you go to change that value) to make selections, use whatever works best for you, but I think 7 or 3 will be your go-to values.

Both MOT_THST_EXPO and MOT_SPIN_MIN are very important and interdependent.
So far on the alphas looks like:

Kind of works, but there are better values.

1 Like

And use plenty of AltHold and some Loiter in the same flight for testing.
This provides a lot of good info, and tests everything both with and without position control.

1 Like

Thanks Shawn! Reviewing and applying now!

I didn’t head to the field today since it’s a bit windy for tuning.

There’s a lot of changes listed by us all, save the param file and upload a copy of that, we can check it again if you like.
A param file will attach directly to the discussion.

Townsend X4 Parameters-011123.param (17.7 KB)

My latest params file is attached. I’ve added a fence.

My MOT_PWM_MIN value of “.1” is based on bench tests. I did have one motor not start yesterday though. It started fine after an FC reboot. Any advice on that?

I’ll leave the MOT_THST_EXPO at .2 for now since that is working on several of my other Alpha builds.

You could set
since there’s little chance of a fly-away, everything is working quite well.

I think you could very safely try
since that came from actual thrust tests of the T-Motor integrated motor/mount/ESC combos. I’ll see if I can find the reference somewhere…

Maybe bump up the MOT_SPIN_ARM to 0.1 or 0.11 to get reliable startup?

I would also increase MOT_SPIN_MIN correspondingly between 0.12 and 0.14 as amilcarlucas says. This affects the expo and hover thrust calcs, and all those feed into Autotune.
MOT_SPIN_MIN can be critical to get right to ensure there’s no desync during descent or wind gusts. I’ve certainly seen a lot of the T-MOTOR Alpha and Flame ESCs up in that range or more for MOT_SPIN_MIN.

I’ve made these changes. Thanks!
Townsend X4 Parameters-011123.param (17.5 KB)