I need help Auto flight does not work

Hi guys.
I installed two tfmini plus in the pixhawk 4 on the hexacopter, forward and downward. Changed “PRX_TYPE” from 0 to 4 Ranger Finder to activate the sensor. Oaths work well. But there is a problem.
Automatic flight is not possible with “PRX_TYPE” 4.
Do not perform the next mission because you have climbed to the starting altitude of Mission WP1.
Change “PRX_TYPE” to 0 to enable automatic flight.
But the sensors don’t work at all.
What’s the matter?
The log file is linked below.
I need your help.
Thank you.

Hi @Smith,

I had a quick look at the log and it looks like it tried to run BendyRuler even though PRX_TYPE = 4. Could you clarify a bit more how it didn’t work properly? I guess the vehicle would not fly towards the next waypoint?

I see that the RNGFNDx_MAX_CM is set to be very short (only 300 which is 3m) but I think bendy ruler should still work.

I also see that the PRX_TYPE parameter was set to a few different values during the flight (2, 3, 5, 6). This parameter is a “Reboot Required” parameter so after being changed the autopilot should be rebooted. To clarify, setting PRX_TYPE = 0 will disable the proximity sensor but if it’s changed from 0 to some other number (like 4) the autopilot must be rebooted.

Dear rmackay9
Thank you for your comment.
I am learning a lot from videos on YouTube.
Thank you.
Last log did PRX_TYPE 1,2,3,5,6.
The reason is that we expected automatic flight.
But they were not armed.
I’m attaching an automatic flight log file that I rebooted with PRX_TYPE 4 today.
After taking off, we do nothing.
Please review.
Best regards

Auto

Non auto