I have found a serious problem in EKF when using lithium batteries

I have found a serious problem in EKF when using lithium batteries, error compass variance low mid to full throttle. in plane and copter. inject too much noise Has anyone found any solution to this?

Can you provide more details? For example:

  1. How do you quantify “too much noise”?
  2. Why do you believe the problem is related to lithium batteries?
  3. Since you mentioned throttle, it sounds like a vibrations problem. How is your pixhawk mounted?

It’s simple, when lipo batteries are used, all ok. when using lithium batteries EKF error compass variance at almost all times in medium and high speeds.
pixhawk cube mounted on moon gel minimum vibrations.
internal compass disabled.
External compass physically far away and shielded.
Batteries away from FC and compass.

then I send flight log

Interesting, but I think it is unlikely that lithium batteries (18650 cells?) could lead to compass variance, for these reasons:

  • You say the batteries are located far away from the external compass
  • Noisy power probably would not cause compass variance error. If anything, the error would be “bad compass health.”
  • I fly lithium batteries (18650 type), and I have not seen any issues with compass.

Can you take a picture of your aircraft with lithium batteries and also one with lipo batteries? It is possible that different power wiring can cause significantly different magnetic fields.

Also, have you tried performing a CompassMot calibration? This should help compensate for compass variation at high power.

thanks, I’ve tried it but it shows the following message: unsupported preflight calibration

and I can not do it for that reason

What version of ArduCopter and Mission Planner are you using?

A.Copter: 3.5


A. Plane: 3.8
MP: 1.3.56

Are you sure is not just the battery cables path ?

Maybe the spiral nature of 18650 type batteries are causing some magnetic fields that aren’t there in the flat layered lipos?

The tension of the Li Ion pack is lower compared to Lipo packs so you’ll need more Amps , this could explain why you have compass variance error message from low mid to full throttle.
As suggested try to run compass mot .

The voltage and especially current sensor need to be calibrated and working before running compass motor calibration

You should probably qualify what you mean by far away. Shielding doesn’t do squat with mag fields. We have a lot of experience using both 18650 cells and lipos and 18650s generate way bigger magnetic field. There is only two way to avoid bad interaction. Significant distance, which varies depending on how much current is drawn, - for a 1.8 kg vehicle with 3s batteries you will need 2.5-3.5". You need to be mindful of the fields from the wiring between cells too. The second way is to tightly couple the + and - current paths. Takes a while to figure that out and even then wiring up a pack is too much work. My conclusion is it isn’t worth hassle until 18650 are about double their current capacity (3000 with a high current capability).


Had the same problem on PX4.
When you’re using lipo … and change to a liion … you need a new compass calib. (lipo and liion not equal in magnetic terms)
Did you calibrate with lipo ? and change it after ?
Try this and tell us :wink:

I have noticed the same issue. I am using AC3.4 and Li-Ion pack consisting of 9 pcs 18650GA cells. I get compass variance error and I am not able to switch to any of auto modes. I do not get this error when using Li-Po cells.

Physical separation and “mu metal” are the only cures to mag field woes. Only use the external compass and put it as far away as you can.

edit: and do the motor compensation calibration

Did nearly crash the copter today, when using 18650 the first time.
I managed to Switch to stabilize and was able to do a landing. Before the machine was turning around in loiter like mad.
Used tiese packs:

6S3P NCR18650GA 22.2V 10.5Ah 30A/40A 233Wh 666W

The copter has a power consumption of about 22Ah, so should be fine…
I will download the log and have a look at it…Looks like compass and GPS did caouse the Problem and voltage did go down.