I can't connect NodeMcu with Pixhawk2?

I want to add Wi-Fi telemetry to the Pixhawk2 flight controller with a NodeMcu module,like this link

I’ve done to flash firmware(MavLink ESP8266 Firmware V 1.1.1) already and I can connect to for config all parameter such as SSID , Password etc. .But when I connect a NodeMcu with Pixhawk2 like this

Pixhawk2[TELEM1] || NodeMcu
VCC_5V --> Vin

Note>>I set the Baudrate at 57600 all of NodeMcu and Pixhawk2(TELEM1) and I set this parameter already.
SERIAL1_BAUD = 57600

But I found the following problem
1.I can’t connect to the mission planner.
(UDP, 57600 Baud, Port: 14550)
2.After I connect NodeMcu with Pixhawk2, I check “” with my browser I found this below parameter which Packets Received from Vehicle = 0
How can I solve this problem?

Comm Status

Packets Received from GCS 0
Packets Sent to GCS 0
GCS Packets Lost 0
Packets Received from Vehicle 0
Packets Sent to Vehicle 0
Vehicle Packets Lost 0
Radio Messages 0
System Status

Flash Memory Left 487424
RAM Left 13856
Parameters CRC CDCD5ED3

Thank you

Note:This link is my NodeMcu

I have same problem…

Did you solved it?

I also noticed an issue with a NodeMCU and a Ardupilot2.8 (from ebay, so probably a clone). I could not get any serial communication through. I even tried EspLink and other transparent TCP–>UART software and neither of them worked.

Personally I think this is because the ESP need’s a UART level shifter to make it interface with the ArduPilot. I do have a dedicated ESP-07 with level shifter that works flawlessly. The ESP should be 5v tolerant on the I/O’s but maybe the ArduPilot is not registering the ESP’s 3.3v as a logic HIGH.

Same problem here! latest fw 1.2.2 , same nodemcu board.

Fixed. It’s the USB part “disturbing” the comunication. I removed the FTDI chip with hot air and it began to work.