Servers by jDrones

I can't connect my telemetry Radio 433Mhz in Pixhawk Lite


(Roberto Quintela) #1

Hi

I have 2 telemetry radio antenas. One of them I plug it to my PC and I have a com port “Silicon Labs CP210x”. The other one I plug it in the telemetry1 port in pixhawk lite. I Load setting in Mission planner and I save them and the mission planner says done but my radio in pixhawk is in fixed red and when I try to connect after 28 seconds the message is that can not send heartbit pacckets.

I don’t know if the problem is in the position of the wires of the radio connector in pixhawk.

Any idea please?


(Mike Boland) #2

When you power up your Pixhawk and the PC with the radios connected, is the green light on the radios solid green or flashing?

Have you checked out the radio section of the wiki?
There is details on how to connect the radio to Mission Planner and check the settings and update radio firmware.


(Roberto Quintela) #3

Hi Mike

When I power up mi Pixhawk Lite ande the PC with the radios connected. Both radios have solid green light.

I’m following tis steps:
http://ardupilot.org/copter/docs/common-configuring-a-telemetry-radio-using-mission-planner.html

http://learnrobotix.com/uavs/quadcopter-build/pixhawk/mission-planner-wireless-radio-setup.html

But nothing works.

I think that is something related with the position of the wires of RX and TX but I don’t know…

Regards


(Mike Boland) #4

“But nothing works” is a pretty broad stroke, and will probably garner obtuse answers such as “well your not doing it right”.
Can you give us more details please, such as your setup, a pic maybe?
When following the steps, how far do you get?
What buttons do you click on?
What messages result?
What cables are you using?
If you plug each radio into your PC can you read the parameters in the radio section of Mission Planner?
Does it load the drivers?
Have you selected the right com ports?
Have you selected the right baud rate?

Details please.


(Roberto Quintela) #5

Hi
1)The setup is this


2) I get in the flow to the final step but the result is this

3) I have these cable configurations
In the antena air

in the antena ground

I have tried both possibilities:

  • GPS in port 1 and antenna in port 2
  • GPS in port 2 and antenna in port 1
    About the wires I have respected the 5v and ground position in the extreme sides of UART connector and I have tried several positions alternating the green and yellow, so, Rx and Tx but always with the same error.
    4)I have the latest drivers of Windows of the antennas
  1. I have selected 57600 baud rate

Regards


(Mike Boland) #6

From the first pic:
The radios are connecting to one another (solid green light indicates this) and the details match.

Second pic: This is telling you what is wrong, i.e.: no Mavlink data is being sent from the remote radio, so you will need to look at why no Mavlink is present.
You have already stated that you have tried reversing the Tx and Rx lines so that rules out the cable (maybe, have you checked the connectors very carefully? Pins in FC?)
When the FC is connected to the PC via USB do you get a connection?
What firmware have you loaded into the FC?


(mike kelly) #7

The Pixhawk Lite has multipurpose ports. They share functions. So the first port has both GPS and Telem1. Be aware that Telem1 RX and TX are backwards from Telem2. RX from one device should go to TX of the other device and vice versa. If it does not work the first thing to try is swapping RX and TX.

More information on he PHL on RCGroups:
https://www.rcgroups.com/forums/showthread.php?2418029-Pixhawk-LITE-mini-pixhawk-clone


(Özgür Korkmaz) #8

If you flash firmware to one of those modules, you should flash to other one too. I made that mistake and could not connect until I flash air module through Ftdi. If you didn’t touch them on this way, try flashing the firmware to modules anyway. There may be a firmware corruption. Who knows:) If it is a stupid suggestion just ignore me. Good luck.


(Javad Rouhollah) #9

How to flash air module
When iam connecting fdti usb cable pc showsling that the usb is not detected