Huawei mediapad 7 youth 2 android tablet can't find MAWlink

I get no response when I connect the RCTimer Radio Telemetry Kit 433Mhz to the Huawei tablet, which is on the positive list even with the word perfect attached! I have tried in this order as wcp1947 recommend it.

#1 Power up 3D radio on tricopter
#2 Power up Huawei
#3 with droid Planner installed but not open
#4 Plug in 3d radio (to Huawei) as soon as I plug into Huawei
it ask what program to use [color=#BF0000](it’s here it fail)[/color]. then I start DP
#5 then push connect on Huawei

when I run the app MavLinkHub it says disconnected, when I run Android’s USB Host Controller it says “S3C USB Host Driver NOT found!” and USB Host Check says “ not found”, “Handheld_core_hardware.xml USB host not enabled” and “Tablet_core_hardware.xml Not found” and when I click on Fix it says "could not start su process"
What do I have to do?

it turned out that the Huawei doesn’t support OTG/ power to external equipment :frowning: . I bought thi Lenovo A10 A7600-F that do the job right out of the box :smiley: and could be added to the compabillity list. I just don’t know how.