How to turn off the cyclic blade pitch and collective pitch when the helicopter is on the ground

【How to turn off the cyclic blade pitch when the helicopter is on the ground】
When the helicopter is idling on the ground before takeoff or after landing, the PID control of the helicopter is on, resulting in the cyclic pitch controlling the helicopter. Especially when the engine accelerates or decelerates, resonance occurs, and the amount of cyclic pitch will be large, causing the UAV to roll over. Is it possible to turn off the helicopter’s cycle change or turn off its PID control when the helicopter is idling on the ground?

Ask for help!!!

【How to turn off the collective pitch when the helicopter is on the ground】
When the helicopter is idling on the ground before takeoff or after landing, in the Loiter mode,the PID control of the helicopter’s collective pitch is on, resulting in the collective pitch controlling the helicopter. Especially when the engine accelerates or decelerates, resonance occurs, and the amount of collective pitch will be large, causing the UAV to up and down. It is very dangerous. Is it possible to turn off the helicopter’s collective pitch change or turn off its PID control when the helicopter is idling on the ground?

Ask for help!!!

@Flying2015 I moved this to the tradheli topic in the forum. Hope you don’t mind. I didn’t realize you posted on the forum as well. Let’s keep the discussion in this thread instead of PM. Here is my PM in response to yours just to bring this up to date.

Your problem is with the vibration. You should fix that rather than turn off the PIDs. The vibration is either the flight controller mounting method or location or it is the rotor head not balanced properly or both. Post a link to that log and I will take a look when I have time.

Also upgrade to the latest version of 4.0. There was a bug in 4.0.7 unrelated to this issue

You didn’t post this in your PM to me. Again this is most likely a vibration issue. Also please don’t use modes like loiter until you have checked for vibration issues and verified the heli is properly tuned. This is very odd that the collective is moving loiter if the aircraft is on the ground. I think you have a bad setup as well. Have you used the wiki to help you set up this helicopter. If not please read the wiki and follow the process in setting up and tuning your helicopter.

Dear Bill,

I am very happy and grateful for your reply.

Yes, as you said, the problem is the vibration, the resonance of the helicopter. We’ve done the rotor head dynamic balance, and we’ve done the vibration reduction on the flight controller. At present, when the aircraft is flying in the air, the vibration detected by flight control is acceptable, and there is no alarm. We have studied the wiki carefully and the helicopter can fly normally in the air. However, when the helicopter is on the ground, the engine accelerates from idle speed (2000-3000rpm) to fixed speed 6500rpm, and we cannot avoid the resonance of the helicopter. Similarly, after the helicopter landed on the ground, the engine slowed down from constant speed of 6500 RPM to idle speed, and the resonance of the helicopter was also unavoidable.

When the helicopter resonates, its cyclic pitch is unpredictable (we tested version 4.0.7). The collective pitch control was also unpredictable in Loiter mode (we tested versions 4.0.7 and 4.1.2, 4.0.7 was acceptable, but 4.1.2 was very jump-throated). Sometimes, the helicopter will be in a very dangerous situation, such as rolling or bumping up and down.

So, I’m wondering if we can turn off the cyclic pitch and set the collective pitch Aout is the lowest when the UAV is on the ground. In this way, the danger can be avoided. Of course, maybe you have a better idea.

I uploaded my flight log from yesterday (2021.12.29) and flight control parameters. Flight mode is Loiter, version 4.0.7. After landing, when the helicopter exits RSC, due to resonance, the collective pitch of the helicopter is pushed to the maximum (Aout=1), and the cyclic pitch has a large head-up value (Pout=0.48), resulting in the helicopter is off the ground again with a large head-up.

The flight log (4.0.7)

The flight control parameters(4.0.7)
The flight control parameters-4.0.7-20211229.param (19.2 KB)

I also uploaded a log of my flight with version 4.1.2. When the engine accelerates or decelerates, resonance occurs, and the amount of collective pitch will be large, causing the UAV to up and down.
The flight log (4.1.2) Aout up and down

Thanks for your time. I am looking forward to your reply.

Best wishes.

After looking at your parameters, one parameter that looks to be too big is PSC_ACCZ_P. You have this set at 0.7. The default is 0.28. This would definitely drive an instability in the vertical axis if it was too big. I see that this is a dual heli frame with rotors side-by-side like a V-22. How big is the heli? What size rotor system? How much does it weigh?
I will take a quick look at your log this morning.

Good morning, Bill.

Its rotor is about 3 meters in diameter and weighs about 130kg.

I have estimated that the PWM value of the steering gear 13.13us corresponds to about 1 degree of collective pitch. The PWM value of the steering gear of 25.48 us corresponds to approximately 1 degree of cyclic pitch. The 0.15 of “Aout” corresponds to approximately 1 degree of collective pitch." The 0.057 of “Pout” corresponds to approximately 1 degree of cyclic pitch.

Wow! that’s sounds like an impressive helicopter… I noticed that you had only 75 PWM between H_COL_MIN and H_COL_MAX. That is really small. I typically see the range of PWM from min to max of approximately 200 to 250 PWM. Just an observation. If possible, it is always good to have more resolution so that the increments in PWM equate to smaller increments in collective pitch.

Yes the vibration is the biggest problem here.

I noticed that even when the rotor is not turning (Motor Interlock Disabled) that there is considerable vibration in the vertical axis. Is this helicopter powered by an internal combustion engine? It surprises me that this kind of vibration is not shown to be offensive to the EKF and cause attitude drift. So if this is a gas engine then the idle speed of the engine causes high vibrations. You need to figure out how to shield the flight controller from these vibrations. Put it on a stiffer structure or move it away from the engine. Put the engine on a vibrations suppression mount. You need to do something with about this.

@Leonardthall I want to get your opinion on this only because I was surprised to see the altitude controller responding to inputs when it is armed but landed with interlock disabled. I thought that the controller was reset or zero’d while in this state. It looks like it is even worse in 4.1 than in 4.0.
This is 4.0.7

the CTUN.ThO signal looks to be filtered compared to the CTUN.ThI signal

Here is 4.1.2

I looked at the VIBE message and it does look good. Again I’m not sure why you aren’t seeing more issues with the EKF when there are deviations in vertical acceleration of 10 m/s/s. Typically I am use to seeing acceleration deviations of around 2 m/s/s.
here is the accels from a flight with my electric 600 size heli.

You can see that even on the ground with the motor running the accel deviations are 2-3 m/s/s. It shows a segment when I was landed with the motor off and there were still some small deviations with the heli just sitting there.

For the collective total pitch, H_COL_MIN corresponds to approximately 1 degree of collective pitch. H_COL_MIN corresponds to approximately 8 degrees collective pitch, which is the maximum total pitch the engine can drive. The total hover pitch is about 6 degrees collective pitch, which corresponds to an Aout of about 0.7.

Yes, it’s a four-cylinder piston engine. Vibration reduction is very difficult, in fact, we have done many, many things to try to avoid the impact of vibration on flight control. We’ve worked very hard to keep Vibes under 30. In your opinion, how much vibration should be controlled? How do you observe that?

@Flying2015 To answer your original question, yes there is a way to turn off the PIDs but I’m not sure this includes the altitude controller. it is an RC options function called Standby Mode which turns off the PID loops and after reading the description, it turns off the altitude PIDs too. Here is a link to the wiki page

There is still a problem with using this. The controller is not detecting landing. I think that this is caused by the vibrations in the vertical axis keeping the vertical speed from becoming less than 1 m/s for the required time. So it is important that you get the landing detector working as this becomes very important for autonomous missions to allow the autopilot to know when it is landed and then be able to safely shutdown.

One way to help the altitude controller with these vibrations is to use the low pass filter PSC_ACCZ_FLTE. Set this to 10 hz or maybe even 5 hz to help remove the vibration from the signal.

I envy your acceleration data. I wish I could have your acceleration data on my helicopter.

We don’t have a better idea of vibration, probably because it’s an internal combustion engine. In particular, the ground vibration problem caused by the change of the cyclic pitch and the collective total pitch is troublesome. The only way I can think of is to shut them down on the ground.

I think a large part is due to the engine. I know a user that would balance his pistons/crankshaft to achieve lower vibrations. From what I understand some engine manufacturers are better than others on this. You may want to look that up. I don’t work with gas engines.

Thank you very much. I will study the materials you sent and try your suggestion on parameter adjustment. After I finish testing, I will continue to give you feedback.

By the way, the helicopter doesn’t hover very well in Loiter mode. It swings, especially when there is wind. Could you give me some advice on parameter tuning through the log?

Do you mean the POLINI THOR 250 DUAL SPARK engine?I’ve heard of similar treatment.

Hello, Bill. If we lower the lowest collective pitch,in your opinion, whether the vibration will be better on the ground?For example,we adjust the lowest collective pitch from 1° to -2°. The max collective pitch is still 8°. However,the hover Aout will be about 0.8 or more. Is it a problem? (Because the hover collective pitch “Aout” is suggested 0.2-0.8)

Don’t know much about these. Here is a post from a user whom I was referring to. He mentions a little bit about counter weights on the crank shaft to reduce vibration. But he also mentions what engines worked best for him.

Probably not. As you get more negative collective pitch, it will probably get worse. but I would suggest that you give yourself at least -2 deg for the minimum.

I would suggest increasing your rotor speed to keep within this range. You may be running your rotor speed to slow if you are near 0.8.

Yes, you are right. However, the power of the engine is limited. Thanks for your contribution. Today, according to your suggestion on the forum, I adjust the Angle-P from 3.5 to 6. The state in the loiter mode become better. I’m happy.

I hope that my problem about the resonance could be solved later.

Happy new year!

Glad to hear you were able to get a better tune.

There is nothing from a code perspective that ardupilot can do to help with this. Vibration is something that has to be managed mechanically as much as possible. I have never encountered a user with the vertical vibration like your helicopter. Leonard and I will look at how it affected the altitude controller out of curiosity and determine if this an issue for more reasonable levels of vibration.

Happy New Year!

Thanks for your information.