Servers by jDrones

How to switch on altitude above terrain paramert?

Greetings.

I have a question how to create an automatic mission flight in Qgroudcontrol, taking into account the terrain. The UAV must maintain altitude, taking into account the terrain.

My system parameters:
Pixhawk 2.4.8
Arducopter - version 4.0.6
Qgrouncontrol - version 4.0.11
Lidar - Benewake TFmini Plus 12m

I went through all the possible combinations of the following settings, but I could not create a mission in which the height would be measured using a lidar. Screenshots of the settings are shown below.

!

! !

I set up the lidar and made sure it was in manual flight mode.

Made the settings according to this page:
https://ardupilot.org/copter/docs/terrain-following.html#terrain-following

But the UAV, when trying to flash the mission, started downloading location data from the server. I realized that this is not my option.

I have looked into the assignment of parameters on the settings page
https://ardupilot.org/copter/docs/parameters-Copter-stable-V4.0.6.html

Realized that the TERRAIN_ENABLE parameter should be set to 0.

Set the TERRAIN_ENABLE parameter to 0, reboot the system. Expected to see “Altitude Above Terrain” item, but it didn’t.

Examining the Qgroundcontrol code, I see that this option is there, but I don’t understand how to activate it.

Does somebody know what to do to swith on altitude above terrain in auto mission?

Servers by jDrones