How to stop entering LAND?

Hi there. Running 3.1.5 on a 3DR X8 with Pixhawk.

Even though I have the battery failsafe disabled, when the battery gets low FAILSAFE comes up on the mission planner screen, the buzzer starts going off, and the copter automatically enters LAND mode. This is not desirable behavior. I rely on a battery alarm attached directly to the lipo’s balance plug, which I trust much more than the 3DR power module. Once that beeps, I know I have around a minute to land. I don’t need the copter to enter land mode automatically, potentially over an unsuitable landing site.

So how do I stop this behavior? I already have the battery failsafe disabled. Thanks!

please post a .log from such situation.