Servers by jDrones

How to set up elevons?


(Hugh Neve) #1

Hi,

I have searched for an answer - here, and via Google, but haven’t found an answer that gets things working.

All I want is to set up the aircraft with elevons:

  • Hardware: v2.8;
  • Firmware: Ardupilot v3.4.0;
  • Mission Planner: 1.3.52;

Under ‘Initial setup’:

  • The radio is calibrated and the ‘elevon’ tickbox is ticked;
  • The options adjacent to the servo outputs on the Servo Output screen are greyed-out;
  • The Servo Output screen shows the pitch /roll servos in the usual elevator/aileron rudder config, as does the ‘Failsafe’ screen;

Under ‘Tuning’:

  • I’ve changed the Elevon parameters;
  • I’ve changed the Servo parameters

I’m at the point where it is ‘change-on-change’ and sequential changes are cancelling out each other. Mechanically, the servos work perfectly but not as configured as an elevon aircraft.

Any assistance with resolving this would be very much appreciated - I need to escape the loop in which I seem to be stuck…

Thanks,

Hugh

PS. If it helps, the current param file is attached.

param list.param (5.7 KB)


(Dave) #2

Try changing these parameters to these values and leave ELEVON_OUTPUT at 2
ELEVON_CH2_REV,0
ELEVON_MIXING,0

You may have to change ELEVON_CH2 direction to suit.


(Hugh Neve) #3

Thank you Dave, the servos are now moving together - but in exactly the wrong direction, even with ELEVON_CH2 reversed.

Its great to progress this far but I must still be missing something. Any ideas, please?

Thanks,

Hugh


(Dave) #4

You are not using an elevon mix in your transmitter right only in the FC? Are any of the elevon checkboxes ticked now in MP radio calibration screen?

The problem here is we are working with old stuff. I set my wing up with an APM, probably what you have, a couple years ago and recall going thru the same circular logic before getting it right. Maybe my setup and parameter file will help:
Chan 1 AIL right side servo
Chan 2 Ele left side servo (reversed in Tx)

Parameter file attached.
z-84 wing.param (5.7 KB)


(MagicRuB) #5

Why are you running such old firmware? Please upgrade to ArduPlane v3.8.x and report back if you still have problems.


(Dave) #6

Speaking for myself my Plane has an APM FC which isn’t supported beyond V3.4. I’m making the assumption this is true for Hugh also (Re: hardware 2.8) but if not by all means update to Arduplane current stable.


(MagicRuB) #7

right, old hardware strikes again.


(Hugh Neve) #8

Thanks Dave, I’ll use your param files as a starting point.

TBH, I wasn’t aware of hardware newer than 2.8.

Thanks
Hugh


(Hugh Neve) #9

Thanks Dave,

That’s fixed it.

:grinning:


(Dave) #10

Great! Yes, the APM is getting long in the tooth now. Since April of 2015 it has not been supported by continuing revisions of Ardupilot due to hardware limitations and the addition of new features. But of course it’s still flying plenty of craft. I have retired all but one of them in my Plane and Multirotors. Pixhawk and Pixhawk variants (there are many) are a much more capable Flight controller and continue to take advantage of further firmware development. If I was to re-build my Wing today I would use a PixRacer (a variant) as it’s small and I have a lot of experience with them on Multirotors.


(HughN) #11

Then a PixRacer it shall be for my aircraft too…