How to set up a polygon geo fence in copter

OK, I want to set up a polygon geofence. I have followed the directions. In the image below, the box that says “Type” mine is always blank. I did succeed in setting up a cylindrical fence I think but now sure. What is the trick?

You seem to have found a reproducible bug in MP. Issue raised.

Read the second link I sent in the other topic. You’ll be on the Plan screen for polygon fences. I’ll try to post an example a bit later.

1 Like

Here’s how to set up a polygon inclusion fence manually.

First, connect to your Copter, enable fences and set the FENCE_TYPE bitmask to enable polygon fences. At a minimum, bit 2 needs to be set (value of 4). In this example, I have also enabled a max altitude of 100m.


Now go to the Plan tab and select FENCE from the dropdown in the upper right of the map.


Now select “Draw a Polygon” by clicking on the polygon tool in the upper left.


Click on the map to draw the points that define the fence.


Click again on the polygon tool and select “Fence Inclusion.”


This should populate the waypoint table with appropriate values and change the drawn polygon to a fence.


Now upload the fence to your Copter by clicking “Write.”


If done correctly, you should now be able to see the fence on the main Data tab in Mission Planner, and it will be active.

I sorta figured out a bit of this but your explanations helps a lot.

After the fence is written, if I reload it, does the fence appear along with the saved auto mission? I hope so and will test it tonight.

I still don’t know why I get the blank slot when trying to set up a fence using config?? I did briefly see a you tube video that had the blank option populated with something.

Because Mission Planner and Ardupilot are not advancing at the same pace. Different developers with different priorities. It’s the way it is. You need to just suss it out.