How to set telemetry only without autopilot?

Dear friends

I have an orange cube with 900x radios. For the project we are developing, we need a very quick connection from the cube to the ground station. The cube is mounted in a real airplane, therefore we do not need autopilot parameters. To speed up the connection (the parameter load takes a long time… I have already checked this in other forums), I am looking to remove autopilot parameters from the quadcopter or airplane firmware. The tracking antenna firmware loads very quickly but it does not have all the parameter settings required by my GPS to make it work.

What would be the best approach to solve this problem?

  • Removing parameters from the airplane or quadcopter firmware - how can it be done?
  • Adding additional GPS parameters for the tracking antenna firmware
  • finding a firmware for this specific task - telemetry only (GPS + accelerometers).

Thank you a lot!


Make sure you’re using MAVLink 2. That should enable MAVFTP, which is very quick to transfer parameters.

Dear Yury, thank you for your reply.

When I hit “stats” I see MAVLink2 is enabled. When the “param.pck” is being loaded it says that MAVFTP 1-1 is loading the .pck file. So I guess it is already enabled.

In other forum it was also suggested to uncheck the RTS/ CTS, and it reduced the initial time-out time as soon as you hit connect.

I am also experiencing repeated parameter loads (when using the quadcopter 4.2 firmware). The strangest thing is that when I installed that firmware everything was loading in less than 35 seconds. I took it to another computer and ok. I took it to a third computer and it loaded the standard parameters (many) and from that moment on it no longer loaded fast on the first 2 computers. It is really strange.

You may have an unstable telemetry connection. MAVFTP doesn’t tolerate a lot of loss, and if it fails, Mission Planner will revert to gathering parameters individually.

If you want to use ArduPilot on your Cube for all the convenience that it brings with native hardware/sensor support, you’re going to have to let it gather parameters. Many of them are used by Mission Planner (or any GCS) to configure the interface properly.

You can always write a custom firmware version that pares down the parameter set, but I fear that will be a very tedious process and probably not worth the time vs troubleshooting the telemetry connection.

Thank you again for your kind reply. Could you direct me to any forum to improve the telemetry connection and if possible give me some tips? Unchecked ECC and RTS / CTS may have something to do?

I think the RTS/CTS info is old. Flow control should improve the connection. I think @dkemxr has a bit of experience with the details of radio setup and perhaps could help here.

If you want a slightly easier way to get custom firmware than editing the code, you can use the online firmware builder and only check the options for hardware you want to use. However, I don’t think this will significantly impact parameter download time. It should reduce the parameter set for unused hardware libraries, but I don’t think it will be significant enough to warrant the exercise.

ArduPilot Custom Firmware Builder

Thank you again. Quite honestly I was totally lost with what happened to me and I told you how the connection behaved in 3 different computers, and how it was slow since I connected it in the last one.

That’s a good piece of advice as I do not need autopilot parameters at all. As I mentioned the tracking antenna firmware would be excellent as a base, but it does not work as the GPS (model 9) requires some extra parameters to work.

Some of these radios can receive significant interference when placed close to the host computer. Try a longer USB cable as well.

Thank you, I will try doing it as well

Here are my settings on the cheapest, most interference prone radios I have (they were cheap HolyBro knock-offs from Amazon):

Even with their sensitivity to RF interference, parameters download in a few seconds, and I get a good connection that even works reliably for RTCM3 injection (RTK GPS).

Thank you so much Yuri, we are going to test it and I will let you know how it works.

Warm regards,


1 Like