Servers by jDrones

How to reverse in Ardupilot Rover

(Peter Burke) #1

I have a brushed motor w/esc.
When I give it 1000 microseconds it goes in reverse, 1500 neutral, 2000 forward, using a servo tester.
But in Ardupilot rover, using servo3 output (70 = throttle), it only sends 1500-2000 ppm when I advance the RC control (ch1) from 0 to 1000 % (1000 - 2000 microseconds).
I have the mot_pwm_type as normal (0).
Is there a way to have Ardupilot send between 1000-1500 to go in reverse?

(Sebastian Schürmann) #2

You need a spring loaded throttle stick, that centers during RC calibration. I use the pitch stick for throttle input on my rovers and the unsprung throttle stick for gimbal tilt.

(Joe) #3

I am having some problem getting my brushed ESC (Modelcraft 15 T/75A) to work. When using mot_pwm_type as normal (0), the ESC calibrates but since the throttle is not in neutral, it starts flashing green instead of a steady green. Therefore, no commands are sent to the engine and the rover just don"t move.

How do you insure the value stays at 1500 till you decide to go forward or backward?

I like the idea of using the pitch stick for throttle input. Could you please share your configuration? I am somewhat of a newbie at this.

Thanks for your help.

(rmackay9) #4

@joefrancois,

It might be that the SERVO1_TRIM and SERVO3_TRIM values that are to blame. They should be set to 1500 normally. If this is not the issue then maybe post a dataflash log so we can dig into it further?

(Joe) #5

I figured out what was the issue. It was simply a power issue. I don"t know if my Pixhawk power cable is broken, but for some reason it was not powering the brushed esc. Furthermore, the BEC on the servo rails was sending power to the ESC giving the ilusion it was getting power. I now removed the BEC and let the ESC power the servo rail and I provided the ESC with its own power. It is working great, now I just have to figure out how to get my VL53L0X range finder to work so it stop banging into stuff.

Thank you for your help.

1 Like
(Peter Burke) #6

Yep that was it:
I had RC3_TRIM at 1000.
Once I changed RC3_TRIM to 1500, forward and reverse worked.
Thanks!

1 Like