How to read data from Telemetry with APM

Hi everybody,

I’m trying to communicate through telemetry in APM with the set up illustrated by the picture below:

I’m able to read and configure some information from the telemetry modules as you can see below :

Then I am able to click on the top right button to connect through usb to UART but as you can see in the “info view” part in the bottom left corner I’m not able to acquire data (everything stays to 0)…

It’s working (I can see data fluctuations in the “info view” part) when my Pixhawk V 2.4.6 is connected directly to my computer but you know … it’s better not to connect the Pixhawk by wire in real flight conditions :stuck_out_tongue:

Do you have any idea how to solve that?

Thank you so much,


I have trouble at those power levels in close proximity perhaps try a lower power setting? Are your TELEM1 serial port settings all at their defaults? Check that it is set to mavlink/57600. Is the indicator on the radio attached to the Pixhawk flashing to indicate it is transmitting? Your connections and radio settings appear to be OK

Hi Jimovonz,

Thanks for the advices.
I tried 1dBm instead of 20dBm but nothing changed.
I supposed the TELEM1 is at defaults settings as I just upload the firmware in the pixhawk and didn’t custom any parameters.
Mavlink/57600 checked.
According to the first picture in my post the big yellow led is blinking and the blue one too. But their comportement didn’t changed during all manipulation so I don’t really know if it’s normal or not and if datas are transmitted…

I don’t really know what to do …

@Jeremy You have done a good job helping to isolate the issue.

The fact that your telemetry radios successfully talk to each other is verified by being able to see/change their settings (such as Net ID, Air Baud, etc.). @jimovonz confirmed this too.

The fact that your Pixhawk seems to work correctly is verified by being able to successfully connect to it via a USB connection.

The big-yellow LED blinking is normal. It indicates that the plane is not ready to arm, due to safety checks. ( It might give us a clue though: Could you look at the video, especially 0:30 sec, compared to 0:45 sec? Is your flashing yellow-led a “double blink” or a “single blink”?

The blue blinking LED is normal, and I don’t know that it gives any info.

Have you tried re-flashing the firmware, just to be sure a parameter wasn’t accidentally changed? If yes, could you use the USB connection to get a .param file, and post it here for folks to take a look?

Also, it should be possible (maybe easy) to try the Telem2 port… that would check to see if it’s perhaps a faulty connection or something. Unfortunately I don’t know how to do that off the top of my head, so you’d have to do some reading or get help from someone who does know…

@hunt0r thank you for your answer and I’m glad my explanations are clear :slight_smile :slight_smile:

I’m happy to say that it’s finally working !
In fact it was mainly a problem of wiring. Referring to the picture below there are two things :

  1. Connector I received has 5 pins and not 6 pins as in the pixhawk … so that why the black wire is out of the connector to catch the ground. (This aspect was already solved before I post this topic)
  2. I solved my problem by reversing yellow and green wire in the connector to be as in the picture. In fact I read in the internet a wrong connection so that why I didn’t have the right connection, so be carfull what we read …

@hunt0r I’m not sure how to get a .param file, could you be more specific how to get it please ?

Thank you,

1 Like

Great work. Since the problem is solved, I think there’s no point in getting the .param file…

But if you’re still interested, Mission Planner has a button on the Config/Tuning screen like “Save to File” when you’re looking at the “Full Parameter List”. That generates a text file of all the parameters, and their values. Which is a .param file.

In deed there is no point in getting the .param file … it’s just for information!

Thank you!