How to enter DFU mode on CUAV Pixhack V3?


I want to upgrade a CUAV Pixhack V3 board to the latest Ardupilot firmware.
The Board is unfortunately still on Nuttx OS with its original (old) bootloader.
The bootloader upgrade instructions on Ardupilot do not work (bootloader upgrade failed message in mission planner).
I assume the cause is that I did not put the board in DFU mode to allow a bootloader upgrade.
I can’t find documentation on the internet on how to put this board in DFU mode.

has anyone help on how to do that ?

For info this is my current config:
27/07/2020 10:55:02 : PX4v2 0029001F 3435510B 32363234
27/07/2020 10:55:02 : Frame: QUAD
27/07/2020 10:55:02 : PX4: de6b667d NuttX: 8c965992
27/07/2020 10:55:02 : APM:Copter V3.4.6 (e707341b



I think you just need to flash the lastest chibios release, and then do the bootloader upgrade!

Good day,
you can update the bootloader using mission planner or using a jtag pins for flash it with an St link or nucleo board

That’s the first thing I tried but it did not work;

I selected this :
Sans titre 1

then ends with an error message from mission planner :
Sans titre 2

At boot time, it detects a fmuV2 and not a fmuV3 bootloader. I guess I need to first find a way to upgrade my booloader from fmuV2 to fmuV3 (CUAV Pixhack V3 is a fmuV3 board)

That’s’ what I tried too and does not work because I can’t find a way to put the CUAV pixhack V3 in a DFU mode. That is the whole question : how to put this board in DFU mode ?

Im not using dfu mode coz i prefer use a jtag programmer for flash my boards.
You can try also in this way… just download from px4 firmware release the version px4fmuv3 and flash it using qgroundcontrol, after this you can check with MP but first flash it with ardupilot firmware

There is no JTAG connector on this board unfortunately. Although I could open the case and start fussing around with tiny soldering spots directly on the MCU, I’m not going to go down that route.

flashing the PX4 firmware with QGroundcontrol will also require the board to be in DFU mode since DFU mode is a hardware thing to allow a bootloader to be written, not a firmware thing. Am I wrong ?

You don’t need dfu mode… for flash the px4fmuv3 with qgroundcontrol

There is another alternative but i must test it first… its using the sd card

I could install the multi-rotor Ardupilot 4.0.3 release (ChibiOS) via the standard QGroundcontrol procedure. Thanks !

So in principle I’m now with a fmuV3 bootloader. However mission planner is still unable to install a firmware on this board.

Can’t you just select the .apj file from here and use the “load custom firmware” option in MP?

No that does not work since it requires DFU mode

There is probably an issue with mission planner for this specific autopilot since it fails to put in bootloader mode (while it works with QGroundcontrol, proving the issue is not the board itself but rather an issue of mission planner not supporting it correctly for firmware upgrades)

Did you try the MP bootloader upgrade after installing 4.0.3? I think once you have a more modern FW on the FC you don’t need dfu mode unless you screw something up.

1 Like

No I did not try that in mission planner after the upgrade to 4.0.3 via QGroundControl. I tried a simple firmware install (which fails in mission planner).
Let me try…

That worked ! Now mission planner succeeds to connect to the board for firmware upgrades. Thanks !