Servers by jDrones

How to enable UAVCAN on Rover 4 ver?

hello, community.
I am building 4 wheel drive elect.rover, with all 4 wheel capable to turn. Board is px4 fmuv5.
I tried to use the latest SW , but the UAVCAN is only present in Plane , not in Rover.
Can anyone suggest, what code should I uncomment (add) to make CAN included ?
I looked through the code and found in “ardupilot/libraries/AP_HAL_Boards.h” that I should have HAL_MAX_CAN_PROTOCOL_DRIVERS to be greater than “0”.
#ifndef HAL_ENABLE_LIBUAVCAN_DRIVERS
#define HAL_ENABLE_LIBUAVCAN_DRIVERS (HAL_MAX_CAN_PROTOCOL_DRIVERS > 0)
#endif

Than in the system.cpp I will have fucntion “can_mgr.init()” compiled and executed:
#if HAL_MAX_CAN_PROTOCOL_DRIVERS
can_mgr.init();
#endif

am I right? if yes, what should I edit to switch it On in Rover ?

I am using two UAVCAN GPS modules on one of my rovers with 4.0 and 4.1-dev. Without changing any files.

How do you run your wheels?
We bought VESC controllers and connected them by CAN. PX4 can send data to VESC, but there is no feedback from VESC. Px4 cannot get the speed, current, etc, from VESC boards.

As far as I know, VESC is not (yet?) supported by ardurover:

https://ardupilot.org/copter/docs/common-uavcan-escs.html

Having an issue with mission planner not saving settings on Matek H743. The CAN P1 DRIVER , GPS TYPE , SERVO1 FUNCTION and SERVO3 FUNCTION. I am running ardurover latest .Currently no compass or GPS shows on the calibration page. I flashed over to plane and it seemed to work. Any ideas appreciated

I am running Ardurover 4.0 on a H743-Wing. I have two Emlid GNSS units connected to it via UAVCAN. I remember the UAVCAN not working during the first boot(s?), but then the GNSS modules suddenly worked. It might have been booting with battery power (USB disconnected), what caused UAVCAN to start working.
I know this is not very helpful, but I did the other setup steps, saving the UAVCAN troubleshooting for later and the rover just a had a GNSS 3D fix at some point.

I can’t even get the settings to stick. The project will be all but useless if the GPS doesn’t connect. I will continue on . I can’t update the firmware through mission planner as it doesn’t recognise the FC. I have whatever the latest rover is currently installed.

Then there is something wrong with the firmware upload. I can use my H743-Wing like any other FC with Missionplanner.
I would recommend to try and do the initial upload with bootloader from the betaflight configurator again.

1 Like

I tried again . Reflashed ardurover latest. Same issue. Not sure where you got rover 4.0 for Matek h743. Can’t find it listed in the firmware pages.Please supply a link to the download if you can. I flashed back to plane and was able to save any settings including uavcan. The GPS worked fine with plane.

I think the problem lies in the fact that I cannot save anything to the Matek h743 when the rover firmware is loaded onto it.

Servers by jDrones