How to disable the ESC inactivity alarm tones?

On my drone use pixhawk4 ( the same with pixcube orange and pixhawk) after few minutes not used I have a alarm (bip) I would like delete this alarm , but I don’t find the parameters to modify.
In advance thank you so much for your help

Some ESCs have an alarm feature. It will activate if you leave the ESC powered without raising the input signal for a set amount of time. Where does the beep come from? The autopilot or the motors?

It sounds like the ESC time out beep, you can disable this with the ESC configuration software usually.

Thank you so much for your help
The alarm is from esc , I tested now it’s okay

Did you find a way to avoid the alarm in any other way than arming and flying?

its a setting on your ESCS, if they are Blheli you need to use the blheli app.

Thanks! Then I’ll look at the ESC settings (using Blujay).

I was hoping there was a dshot command for telling the ESC that the FC is alive. The beeping is useful if/when “landing” in the big crop field next to the airfield :blush: But maybe the probability of the FC being dead but the ESC working is so low that it doesn’t matter.

ardupilot has a lost model alarm function, i think its function 30.

1 Like