Servers by jDrones

How to configure radio in Revo board running Arduplane


(Frankie Fung) #1

I just flashed Arduplane firmware V3.9.4 into an OpenPilot Revolution board using iNAV configurator in Google Chrome. Gyro works as seen in HUD of MP. However when I do radio calibration, the screen appears as attached, and not allowed to calibrate. Servos do not move in response to Tx stick. Rx works when bypassing the Revo board.

Since Arduplane V3.9 is the first version capable to run on non-Pixhawk FC (in my case, Revo) using ChibiOS, is there something to do with this OS! ? What should be done to configure the radio , RC parameters in Configuration tab of MP ?


Appreciate your help.


RC input for as n Openpilot Revolution
(Nathan E) #2

Looks to me like a Mission Planner GUI issue. If you check the status bar for the values, you can do the setup manually by changing RCn_MIN, RCn_TRIM, and RCn_MAX in the full parameter list. (n is the channel number) The first 4 are the most critical to get correct, but if the’re off a few PWM, it’s going to be alright.


(Frankie Fung) #3

Hello Nathan,

Really thank you for your help. Attached are the screen captures of the status tab for RC 1-4 in and out, and also RC 1-4 in Full parameter list. The appropriate values are there already.

But the servos still don’t move. It seems the PWM signal received by the Rx do not get through the Revo board. (I connected the servo directly to the Rx, bypassing the Revo board, the servo moved.) When I power up the Tx, the “No receiver” message still appear in HUD. Usually this message disappears when I switch on the Tx.

The servos do move when I tilt or roll the Revo board, just the radio signal can’t get through.

Any other hint ?

Thank you again for your help.


(Nathan E) #4

It shows that your channel 3 in is zero. Also make sure your mode channel has values. Channel 1,2, and 4 look like they’re getting good inputs. Once 3 has input, I bet that will clear things up.

Switch to manual mode or FBWA to get servo movements. RTL doesn’t work well for setup.


(Frankie Fung) #5

I just tried a lot of things, including :–

  1. re-bind the Rx at 100% throttle travel (instead of -150% to program throttle failsafe)

  2. uncheck the throllte failsafe box in failsafe page of MP, mode becomes manual, still can’t change the mode.

  3. checked the wiring, including the flight mode, they are correct…the orange wire from the Revo board goes to the Gear channel of Rx, and the set up in the Tx for flight mode has been used in many instances, including plane and quadcopter, proved to be okay.

  4. checked that there is 5V supplied from BEC to the output pin of Revo.

Switched to manual, FBWA or whatever mode, still no receiver.

I agree with you that if I can get Ch3, the problem will be solved. But how ? Weird.


(Nathan E) #6

Do you have RC inputs on other channels? It looked like your screenshot showed 1, 2, and 4. Anything else?


(Frankie Fung) #7

The last screenshot (of all the 3) shows RC2 to RC4 which includes RC3.

Sine the last email, I flashed the Revo board back to its original firmware, configure it to work on LibrePilot GCS 16.09, and everything works fine, including radio. This is to prove the board works alright.

But when I flash it back with arduplane, and using the same components, same ESC, same motor, same Rx, the same thing happens again…“No RC receiver” on HUD shows as soon as Tx is power up. From my past experience with MP, whether on arduplane or arducopter(incl trad heli), on both APM2.6, Pixhawk and Pixhack, all the channels connected should have signal show up in Radio Calibration page, and “No RC receiver” message should disappear when Tx is ON.

I am totally at a lost.

Appreciate your continued help.


(Frankie Fung) #8

Hello Nathan,

Further to my last email, pls find attached the photo of my Revo board connection :–

Ch1, Ch 2 and Ch 4 ----- connected to 3 servos for aileron, elevator and rudder

Ch 3 ---- connected to BEC of ESC, and 5V output confirmed by voltmeter when Lipo is plugged in.

Arduplane 3.9.4, MP 3.6.1, DX7s.

ESC and Rx proved to work when board is flashed with Revo original fw.

FYI, when I flashed the board with arduplane using iNAV, I chose “Full chip erase”, so all the setting for original Revo is erased, and should not affect the board when running arduplane. Do you agree ?

The arduplane firmware (arduplane with bl.hex) is found here :–

http://firmware.ardupilot.org/Plane/stable/revo-mini/

Pls refer to the middle of this page of the following link, and draw attention on ChiBios related to the support of Revo board by Ardupilot. Not sure if this poses any problem.

http://ardupilot.org/plane/docs/common-openpilot-revo-mini.html

Thank you.


(basti) #9

@wcfung1 that picture was very helpful. ardupilot revo(mini) port does NOT support per-channel PWM input, see http://ardupilot.org/copter/docs/common-openpilot-revo-mini.html for reference. it requires to use a single wire collective / sum RC signal like PPM or sBus on the RCInput pin. on fullsize revolution you want to connect your RC receiver‘s sum signal to your FC‘s input Ch3 (yellow wire) per default. that’s the 7th pin (incl. GND and Vcc) on the 10-pin Flex-IO port.

cheers, basti.

PS: on a second look i see the wiring picture on top of the revolution(mini) hardware page is somewhat misleading regarding RC input, while the text part is correct. i‘ll get that fixed.
this is the diagram aligned to ardupilot port specs:


(Nathan E) #10

@wcfung1, I’m sorry I don’t have experience with the Revo Mini, but it looks like @vierfuffzig cleared things up! If you want more information about compatible radios, this wiki article might help.


(basti) #11

thanks @Naterater and @wcfung1 for noticing, i‘ve tried to clarify the Revolution(mini) hardware page respectively:


appreciate reviews.

cheers, basti.


(Frankie Fung) #12

Thanks Basti.

The radio works right away as soon as I connected an original PPM Sum encoder (see attached) between the Rx and Revo. By trial and error, the flight mode male to male cable from channel 5 (usually gear channel) of Rx has to go to PWM 8 (the last pin set of encoder) instead of PWM 5.

Now another problem still exists. I set up 6 flight modes in Tx. All the 5 modes work, except when I switch to AUTO, the HUD shows RTL mode which is the next mode. However, when in AUTO mode, the PWM values fall within the pre-set range of that mode and I set that as AUTO. But the HUD and the speech all indicate RTL. See attached screenshot. Any clue on what’s gone wrong ? I am not a developer and can’t solve this kind of porblem.

Will try another encoder and let you know the outcome.

Anyway, thanks very much for your help.

Frankie


(Frankie Fung) #13

Thank you Nathan, the radio works once I connected an encoder between the Rx and Revo.

There is still a minor problem on wrong flight mode among the 6 modes I set up.

Hope Basti can help.

Anyway, thanks for your help. Really appreciate.


(Frankie Fung) #14

Hi Basti,

Thank you for the rework. I further tested the flight mode issue with another encoder from here :–

https://www.goodluckbuy.com/index.php?target=products&mode=search&subcats=Y&type=extended&avail=Y&pshort=Y&pfull=Y&pname=Y&pkeywords=Y&cid=0&q=PPM+Encoder+Board+V1.0+for+APM+Pixhawk+PX4+PPZ+MWC+Flight+Controller+&x=0&y=0

The same thing happen as with the other encoder, that when I switch to Flight mode 2, the PWM values fall within the pre set range, but HUD and speech indicate RTL mode, instead of AUTO. I then tried all other modes for Flight mode 2, they work well. So there may be something to clear up.

Thank you for your effort.

Frankie


(Nathan E) #15

For Auto mode to work, you will need to plan and upload a mission. In the absence of any waypoints or a takeoff for command, it will automatically switch to RTL.


(Frankie Fung) #16

Hello Nathan,

Thank you for reply. In fact, the AUTO flight mode works today when I switch to Auto, without

planning or uploading a mission. So no waypoint or take off command, it still works. And this is the case in many instances when I first set up FCs such as APM2.6, Pixhawk or Pixhack.

The FC accepts the command from Tx and switches to that mode, without executing the command in the

absence of suitable conditions.

Merry Christmas.

Frankie


(Frankie Fung) #17

Hello Nathan,

Correction to my last email regarding AUTO mode. I mixed up with other set up which I am doing at the same time. This set up is AMP2.6 running Arduplane. The AUTO mode works without planning or uploading a mission.

When I go to another set up…Revo board running Arduplane, it works as you described in your last email… that you have to plan or upload a mission and the AUTO mode works. When I delete the mission and waypoints, AUTO modes becomes RTL. Sorry for the confusion.

There is a lot to learn and so many things to remember, and it is up to the developer to decide on how the board runs.

Cheers


(basti) #18

@wcfung1 this is the updated revo(mini) hardware page: http://ardupilot.org/plane/docs/common-openpilot-revo-mini.html

thanks for your reports and observations!

cheers, basti.


(Frankie Fung) #19

Hello Basti,

Thank you for updating the hardware page. In the photo, it shows telemetry radio is connected to either main port of flexi port.

I have got an Optilink ground module to work with the 433MHz built-in modem. But this telemetry set up does not work when the board runs on Arduplane, and the Mavlink protocol does not work in Revo board. Pls confirm, and advise what radio/protocol can be used in Revo when running on Arduplane.

Also when Revo runs on Arduplane, how do we monitor volatge and current since there is no port for power module on Revo as we have in APM2.6 or Pixhawk ?

Thank you for your support.

Frankie


(basti) #20

hey frankie,

mainport is the default serial telemetry port (SERIAL1), using mavlink at 57kbaud per default.
flexiport (SERIAL3) defaults to GPS.

i don‘t have a fullsize revo myself, only revomini, but afaik the fullsize revo‘s onboard 433Mhz modem is not supported under ardupilot fw. unless you‘re using a bidirectional RC system, you‘ll most likely want to use a separate telemetry modem connected to mainport.

for battery monitoring check the connection diagrams, there‘s voltage and current pins on the sonar port. you can either connect a standard ardupilot-type current sensor with 3.3V adc output or use a simple current divider for voltage monitoring like this: https://opwiki.readthedocs.io/en/latest/user_manual/revo/voltage_current.html

cheers, basti.