Servers by jDrones

How to change Telemetry Radio UART on Matek F-405 Wing

Hello. I’m trying to assign a different Uart for the telemetry radio. By default, it appears only to work on UART 1. I’d like to assign it to UART 2. Can someone point me to the right direction? I’ve trying going to the serial protocol option in configuration and setting serial 2 to mavlink (tried mavlink 1 and mavlink). But still cannot connect via Uart 2. I’ve successfully been able to connect the telemetry radios while in Uart1.
Any assistance is greatly appreciated.

serial2 is used for RC input. see http://ardupilot.org/copter/docs/common-matekf405-wing.html for reference. choose a different serial port.

Thank you @vierfuffzig for your quick response. Greatly appreciate it. I did try uart5 as well as a test and still am unable to connect. Any additional settings I should take into consideration should I want UART5 or 6? Should I specify Mavlink1 or Mavlink 2 option with the new UART location?

Thanks again for your help on this. It’s been several hours trying to solve this last piece of the puzzle.

i’d suggest to look at the default settings that obviously work for SERIAL1 and copy them to the SERIALn port you want to use for connecting your telemetry radio instead. there’s no good reason to not work on any other serial port too as long as you get the settings right (protocol, baudrate etc.).

1 Like

Thanks again. I’ll continue giving it another try…always better looking at it with fresh eyes. Perhaps I missed something along the way. Again, thank you for taking the time and helping me, greatly appreciate it.

1 Like

Finally got it working. It appears the wiring for rx and tx was reversed (in addition to trying to conect to UART2). Normally tx goes with rx and vice-versa. It seems the 3dr telemetry radios I’m using requires rx to rx and tx to tx. It is now connecting successfully on UART5. Thanks again for your assistance.

good to hear you got it figured!

Servers by jDrones