How to avoid the calibration on 3D accel again after restoring the all saved parameters from file?

I am a newbie in Traditional Heli. Due to some problems in my Pixhawk 2.4.8, I have to reset all the parameters in my Pixhawk, and then load all saved parameters from file and write all parameters into this Flight Controller. After that, I tried to power it up and connected it to Mission Planner. I got the message “PreArm: 3D Accel calibration needed”. I tried to avoid the calibration on the accel again in the heli, because when I first calibrated it using a simple bench (a small flat board), I got much more accurate angle measurements than those can be achieved in a heli. I thought if I have successfully restored all saved parameters, I can avoid the calibration on accel again.

Could someone please tell me any parameters I can set to make the Pixhawk think I have already recalibrated the accel? I don’t want to just disable the “arming_check” parameter, because that might cause some other unforseen problems in other areas.

Thanks a lot in advance.

Remove compass related parameters

In full parameter tree, do a printscreen of all INS_ACCEL_ID# and COMPASS_ID#, then set them to 0 and hit “write params”.
Then enter the previously screenshotted values, hit “write params” and reboot.
You should be good to go. Remember that this procedure relies on the fact that you have previously performed a good calibration and it only clears the prearm checks.