How to avoid full throttle in reverse on boot without radio


When I start my rover with radio on it just sits there as long as I have the throttle at the neutral position. I boot up to MANUAL mode) but booting up into HOLD mode is similar. If I start without the radio, it takes off at full throttle in reverse in both MANUAL and HOLD initial modes. I’d appreciate some help to avoid this situation.

Radio calibration is such that the PWM range for my Ch3 throttle is 1060 (max reverse) to 1896 (Max forward) with 1495 (neutral). FS_ACTION is set to HOLD, FS_THR_ENABLE is set to 1, FS_THR_VALUE is set to 950 and FS_TIMEOUT is set to 2. THR_MIN is set to 0.

With the radio on, boot up sets the throttle to neutral (1495). If I then turn the radio off, throttle reduces to 900 as per failsafe.

With radio off, boot up sets throttle to 1089… full reverse.

I have tried setting RC3_MIN to 900 thinking that this might override the value set during radio calibration but this has no effect.

I’ve also noticed that I can boot up safely (zero throttle) in both MANUAL and HOLD initial modes if the USB cable is connected to the PC. Doesn’t matter if Mission Planner is connected or not.

Is there any way to get the APM2.5 to boot up without radio and USB such that the throttle setting defaults to either 900 or 1495?



I just checked the APM throttle output with no transmitter on at boot up on the battery and found that the APM throttle output was ~1500.
I use Spektrum transmitters and receivers so there might be an issue with your particular transmitter/radio type.
TCIII ArduRover2 Developer


Thanks for checking it out Tom. Your comments prompted me to look at the problem from a different point of view: I was neglecting the fact that although the transmitter is Off, the receiver is still present and powered up and may have its own set of behaviours in the absence of a signal from the transmitter.

Searching for information on such behaviours revealed the fact that some receivers have built-in failsafe/no-signal functionality and some don’t. Mine doesn’t so I’ll have to make sure I always switch on the transmitter first. I could, alternatively, part with some $$$ for a more expensive radio setup.


This seems a bit worrying as it relies on your ESC not “accepting” a low signal. If “HOLD” is your failsafe action, then I would have thought throttle should go to RC3_TRIM.

What is your RC3_TRIM setting?


RC3_TRIM is 1502.

This, to me, is expected unless I have misunderstood the operation of the FS_THR function. Radio is turned off, Ch3 signal falls below my 950 threshold and APM goes to FS mode. Note that I’m quoting the PWMs as seen on the radio calibration page, not as measured at the APM outputs.

Following Tom’s comment earlier I investigated the availability of a failsafe feature on my receiver and found that there is none (Turnigy 9X). Unless there’s something else I can do I’ll have to ensure the radio is on at boot up or get a more expensive radio.


Watch the throttle output when it goes to HOLD mode to check whether it’s going to 1500 or 900 - I don’t think it shoul be going to 900 in HOLD mode.

Disconnect the ESC - you can do a lot of troubleshooting a lot more safely without the wheels spinning.

When you turn the system on without the radio, what Mode does it go into? MANUAL or HOLD? What’s the initial throttle output?

If it’s in MANUAL mode at startup, it will take FS_TIMEOUT seconds before it registers you don’t have the Tx turned on - until then, you’ll get whatever speed the Rx is outputting. Wait 3 (or however many seconds) and see if it switches to HOLD mode (failsafe).

HOLD is probably a safer mode to start in. Does the APM support “arming”? That would be the safest option.

Check what your mode switch outputs without the Tx connected - it might be setting its own mode. If that’s happening, ensure that the default output puts it into HOLD mode.