How should I resolve the error "System.OverflowException"?

Hi, I’m currently using ArduRover-4.1.0beta to create a skid steering type robot.

I’m currently unable to resolve the error shown in the figure below. I have researched on the internet about this error and could find very little information about it.

This error occurred immediately after setting up TF-Luna Lidar on a MovingBase-based Rover with Rover-4.1.0beta firmware installed.
I once again installed the Rover-4.1.0beta firmware on my Pixhawk CUBE Orange and re-set up Pixhawk.
However, when I re-installed the firmware, I got the same message.

I installed the Copter firmware to test and confirmed that this error did not occur in that case.

Therefore, I assumed that this problem occurs when Rover-4.1.0beta is installed.

If you know anything about the solution to this error, please teach me. Thank you very much.

Just a small thing to suggest: Have you tried the latest beta of Mission Planner? When I run Rover 4.1.0 beta3, the stable version of MP exits unexpectedly when I connect to the rover. The beta version does not.

1 Like

Thank you for your suggestion.

I have tested using both MissionPlanner1.3.74.1(beta) and MissionPlanner1.3.74(stable).
I have found that using MissionPlanner1.3.74.1(beta) caused an error, and using MissionPlanner1.3.74(stable) caused MP to shut down unexpectedly.

More strangely, I ran into the same error when I tried installing the Rover4.0.0(stable) firmware instead of Rover4.1.0-beta.

Sorry to hear. Hopefully others more knowledgeable will jump in.

1 Like

Yes, this is a Mission Planner issue (not a flight code issue) so I’ve sent a note to @meee1 about this. Txs for the report.

1 Like

@meee1 tells me that he thinks he’s resolved MP’s issues downloading parameters. I’ve lightly tested and it seems to be working now.

You probably already know but in any case the latest beta MP can be downloaded by opening MP’s Help screen, then select “Check for BETA Updates” and after a few minutes it should be updated (you may need to press a confirmation near the end of the process).


Thank you both for your help!

Today, I installed the Beta version of MissionPlanner again and confirmed that this error no longer occurs.
Thanks to ArduPilot and everyone involved for the improvements!

Initially, I mistakenly thought there was a problem with the ROVER 4.1.0 firmware.
I am very sorry for this.


No troubles, happy it’s fixed!

1 Like

Interesting and useful discussion. :+1:Thanks for sharing, I appreciate that!

1 Like

hi, i also have a skid steering rover with TF luna and ardurover 4.1 beta 3. My problem is that the simple stop does not work and neither does the bendyruler. The TF Luna reading is correct. In your case, does the rover stop or avoidance in front of obstacles?
Here more details and log.
Thank you in-the-beta-4-1-data-flash-log / 70692/16? u = alberto_ds

1 Like

I’m also currently implementing simple object avoidance by connecting TF-Luna to Pixhawk with Rover-4.1.0Beta installed.
And it’s working well.

Have you updated your MissionPlanner to the latest beta version?
And are there any mistakes in the hyperparameters regarding TF-Luna?
Please check the parameters again.

1 Like

Thanks for the reply! If you can see this thread, you can see the parameters of the TF Luna and the proximity screen working correctly in-the-beta-4-1-data-flash-log / 70692/16? u = alberto_ds