How does Servo Output work? Ground Steering vs. RCIN6

I am building a medium size rover based off of the Razer Dirt Quad using the HolyBro PixHawk 4. I think I have everything wired correctly but I am running into an issue with attempting to limit the travel of a servo. I have a small fpv camera mounted to a gimbal and it is controlled with channel 5 and channel 6 (two knobs on my Taranis). The camera tilts too far back and I want to limit the servo travel to prevent this. My steering is a linear servo from Servo City and I was able to limit it’s travel simply by changing the min and max on “GroundSteering” and the changes were immediate (as soon as I clicked away from the number box). I am not seeing the same thing happening with RCIN6 however. I tried searching quite a bit but was unsuccessful.

I am working in my basement so the rover isn’t armed due to a lack of GPS lock but I have pushed the safety button on my GPS to get all the channels except Throttle working correctly. What am I missing here? Do I need to force arm it for the channel’s min max settings to take hold? Do I just need to do it on the radio and not in Mission Planner? If so why? Do I need to call it something besides RCIN6? If anyone could shed some light and help me wrap my head around what I am missing, I would be grateful.
Thank you all for a wonderful community!

Arming the Pixhawk does not affect the servo outputs (besides throttle channel, depending on your failsafe and arming settings). As long as the rc ch 6 is the correct choice on the remote then there is no reason it should not move just as your ch 5. That is, of course, if you did not also set mode channel to number 6.

Total servo movement of 50 below/above the mid position is not much. Hard to tell what the problem might be, just a few thoughts: If you increase the movement slightly, does it work then? Maybe also try to cross switch the channels 5 and 6 just to rule out that you do not have a problem with the one servo you now use for ch 6.

Maybe I am not explaining the issue correctly. The servo outputs do function, I turn the knobs on my controller and the camera pans and tilts as expected. The issue is I want the travel limited slightly so the camera doesn’t tilt quite as much. I did that with my Channel 2 Ground Steering and it worked fine, you can see that instead of 1100 - 1900, I restricted it to 1250-1750 and the effect was immediate. The same is not true of Channels 5 and 6. No matter what I try to restrict the travel to, the servo pans and tilts with full travel. As you can see in Channel 6, I tried really restricting the travel (1450-1550) and it had no effect. I was wondering if ArduRover treated the first 4 channels differently or it was something I was missing that wasn’t allowing me to tune the servo travel.

Ardurover treats servo functions differently.
Try to set the limits in your transmitter and you should see the servo do what you want.
The other question is, why do you not use this?:

Thanks for the clarification. I saw those options in the pull down menus but I just wanted to keep it simple to start and didn’t want to make things more complex. I may add those types of features later but for now this rover is my idea of a fun learning project.
Thanks again for the reply.