How do you reset a accelerometer

when i calibrate the accelerometer it moves the wrong direction on the mission planner,I have tried to callibrate it right side down when it says left and the right way also but it will not change, when I tilt the copter to the right It tilts left on the screen, front and back aer correct but rt. and lf. are reversed


I think I might have two possible solutions.

  1. When I first set up my copter I had the board pointing in the wrong direction, which manifested itself as the problem you are looking for. I.e, it calibrated right, but after calibration everything was reversed.

  2. Here is a post that explains how to do a reset.

Reply by Xian06 on March 3, 2014 at 5:56am

Same problem was here. But my R7008SB not worked. I update compiled px4io to Pixhawk. After power on only leds blinking no startup tone. I download latest fmu px4 file. Press safety button and power on Pixhawk. And qcontrol can update this file in advanced mode.(config firmware and advanced checkbox)

[ ... -02-22:03/](

Your frame type


And use putty on Pixhawk serial port to enter terminal. cd setup,  erase ,  reset

From : … ed-factory

Hope this helped

it maybe you are just reading the hud wrong as well.
if it helps, turn on russian hud. right click the hud and tick russian hud, it may look more correct.