How do you remove ardupilot from flight controller bring it back to new condition

How can I completely erase flight controller memory so I can install INAV ?
Arduplane just isn’t working out . At the end even removing this bullshit
is proving to be a problem . The only thing I can find online must be a very old method that doesn’t work anymore and is outdated !!!
When I connect ( after 1st power up ) connecting with CLI I get never ending

lol, but isn’t inav much worse? At least that’s what ive heard…

maybe check out this link:

“If this is the first time INAV is flashed to the board, tick the “Full Chip Erase” checkbox.”

Not necessary, write over it. Which Flight Controller?

well you can perform a total erase of the bootloader and firmware using an stlink with the proper tool

Maybe you should elaborate a bit on why arduplane isn’t working for you. For sure it isn’t BS. (By the way, keep this blog without those words). We’re using ardupilot for many years and haven’t encountered anything that couldn’t be solved.

Remember, this is free software. Available to anyone who wants to use. Free, no charge, no payments, no money. And many people around the world are contributing, for free.

So please keep your language polite and respectful.

1 Like

Full chip erase using stm32cubeprogrammer in dfu mode or using stlink

im agree with @Verloop, keep your tones calm without insulting the heavy work of the developers and the work of the beta testers coz they spend time to test every beta release before the stable release.


Perhaps my wording was poor . Im sure there’s nothing wrong with ardupilot and it works just fine for those in the know .

It is exceedingly difficult to join that club with whats available to me to learn from .

If you wish to delete my post entirely thats fine . If I need to do it ( not sure if its possible) then I’ll take care of it .

No doubt ardupilot is like the microsoft windows of the drone world and your trying to be everything to everybody .

Except your trying to control a flying aircraft ! So I get it . We all know how windows worked out …and they spent $billions developing that .

To put things into perspective know that I’m an old timer who started out with balsa wood and 72 Mhz . After a twenty year break from the

hobby I decided to dive back in . As a Mech engineer who programs CNC milling machines all day I’m not entirely deficient in a technical sense so I tried ardupilot .

Thanks for your time

R Champagne

I’m a touch confused here.

This has been posted against “Plane 3.5” - that version is very, very, very old now (about 5 years). Was this post mis-tagged or are you really trying to install Plane 3.5?

We haven’t supported “CLI” for maybe 5 years now. I helped remove it. Its role has been replaced with the use of ground control stations and mavlink. Can you say where you found instructions to use the CLI to configure ArduPilot? It sounds like we might have some clarification to do there.

Can you provide more information about which flight controller you are trying to run ArduPilot on? Others here are assuming stm32 - but I’m wondering if you’ve got an old atmega you’re trying to run ArduPilot on (we haven’t supported that platform for many years).