How do you get QGroundControl working over Wifi using only CRSF?

I have the yaapu telemetry widget working on OpenTX (TX16S) so the required telemetry data is making it to the radio. I am trying to figure out how to get that same date into QGroundControl over the crossfire module’s WiFi hotspot. (I only have the TBS Crossfire TX Lite which doesn’t have Bluetooth).

What I’ve tried:
Enabled “Mavlink On”, port 8888 setting on the crossfire module
Setup a UDP connection in QGroundControl and connected to it

QGroundControl always shows “disconnected” but in the menu: Analyze Tools > MAVLink inspector, I DO see live rssi, remrssi, txbuf, etc. telemetry data. For some reason I’m not able to get the rest of the telemetry data. I shouldn’t have to wire up MAVLink RX/TX from the receiver to the FC because I’m already getting that data to the radio and the yaapu telemetry widget is working an d using that additional telemetry data.

What is needed to get QGroundControl connected and working using only CRSF and WiFi?

1 Like

If you’re using one serial port CRSF for Yaapu then you will need to wire up a second serial port for MAVLink. It does work, but I’ve shelved it for an update or two. It’s just not very robust yet.

The required telemetry data is already making it to the radio using only CRSF. The Wi-Fi module in the crossfire transmitter just needs to send it to QGroundControl. Do you know how to get the extra telemetry data from the radio to QGroundControl, over WiFi?

The CRSF data will not feed the GCS. You need to use MavLink. Follow the post I’ve linked here. There’s been some software updates since then, but the physical idea is still the same.

I was looking through that thread earlier. So it sounds like the remaining steps are:

  1. Enable MAVLink on CH3 and CH4
  2. Wire up the MAVLink connection to TX?/RX? on the H743-WING
  3. Update SERIALX_X to ??? so that it is set up for MAVLink
  4. Try again to get QGroundControl to connect

Do you know the details for what the SERIALX_X parameters need to be for MAVLink?

You’ll need to determine the correct serial port to correspond the TX/RX pads you’re using.

So for argument I’m going to assume Serial 4. On the H743-wing that’s TX3 RX3. SERIAL4_PROTOCOL = 1 (OR 2). The baud rate (SERIAL4_BAUD) should be 57, but that’s probably it’s default.

If you already have the Yaapu over CRSF working the rest should be easy.

I would make sure your CRSF gear is updated to the latest beta versions. And you’ll need to turn on the MAV over UDP on the CRSF menu on your radio.