How do you get Linux version to run?

I’ve tried both versions of APM Planner 2.0 for Linux on a new installation of Ubuntu ver. 14.04.1 but can’t get either one to work. The one called APM Planner 2.0 Ubuntu 14.04 (Trusty Tahir) amd64 2.0.14 seems to install OK but won’t do anything when I try to run it. The other one, APM Planner 2.0 Ubuntu 14.04 (Trusty Tahir) i386 2.0.14, gets an error and won’t even install. Bill Bonney says it works for him but that doesn’t help me any. Can anyone who got this to work tell me how you did it?

in terminal type:

…and post the output here.
I’ve not seen it fail to start, this will be interesting. :slight_smile:

First I tried Linux Mint which I prefer and got the message “Command Not Found”.
Switched to Ubuntu and it just has lots of errors.
It actually started up but when I tried the Firmware Upload got error message of No Permission, perform “Sudo Adduser (username) dialout”.
Did that and tried Firmware Upload again, program freezes with Download=0% and aborts when I click Cancel.
Got a lot of errors in Terminal window saying:
Qobject::Connect: Cannot queue arguments of type 'Qtestcursor’
Error=Unable to open port “permission denied”“ttyACM0”

So far this is even worse that the Windows version!

I am sorry you feel that way, however stating it like that is not very constructive. We will try our best to help you out, but ask that you have some patience.

The issue you are having is a port permissions issue, you do not have permissions to access the com port.

Have you logged out/logged back in after doing the sudo adduser command? Changing your user group in Linux does not take effect until you restart your session. Maybe we should add this to the instructions.

in absence of logs

  • another thing you should have done, is to
    sudo apt-get remove modemmanager

did you do that ?
modemmanager tends to occupy a device only briefly, but it’s initial tests make trouble for any firmware upgrade software that reboots the AP.

Well I finally got it running, had to run it as Root in order to get rid of all the errors.
Even then however it doesn’t do any better than the Windows version! That is, it can only program the PX4 as a Plane, not any kind of copter. When I select a Plane it seems to work and the blue LED eventually comes on and the Red LED goes out. When I try to use any other kind of craft it still seems to work but at the end the red LED is still on so I know it didn’t work. Then, when I try to connect and look at flight data there is no data. It doesn’t even have the ability to read flight data as a Plane and Mission Planner could do that, at least.
Also, APM can’t even tell that a PX4 is connected! If I click Connect it seems to connect but I can unplug the board and the program doesn’t even do anything! I don’t think it ever really checks the connection status or maybe it just doesn’t have any disconnect messages.
The software people on Github are still trying to make Qgroundcontrol work but haven’t had any success after 3 tries but when they get that finished I hope they can start on this one since it’s totally worthless the way it is!

yes,needing root would be a clear indicator that you failed to do as you were told.
If you only spent half the amount of time you complain. to read instructions/provinde logs - I am pretty sure you’d be upn running now.
-I am unsubscribing from this thread bue to no constructive progress…

What do you mean “do as you were told”, what instructions are you talking about, what logs, and why are you such a jerk? If you guys would only spend half as much time fixing all the programs problems as you do writing smart remarks in reply to problems maybe it would be working by now!