How Do I Program The Landing Gear?

I’m trying to set up the retractable landing struts on my 800mm drone. It’s basically a Tarot 16mm base design with the 16mm landing gear servos on a “Y” connection. The problem is there are a lot more parameters in the MP list than are explained in the documentation and when I set everything the way the docs say, nothing happens. When I run them directly from the receiver, they work just fine. Any Ideas?


There are a couple of ways you can set them up…

First. You can plug them into a port of your flight controller let say m7. Then go into the full parameter section and map servo7 to rc12, assuming you are using channel 12

Second way. Set rc12 to option 29 (landing gear). Then plug the retracts into m7 and in MP set servo7 to option 29 (landing gear) .

Either option will you allow to flip the channel 12 switch and your restricts should go up and down

As Dave says (options 29) just make sure the switch position for Deploy is <1200µs and >1800µs for Retract. Also, make sure the output port you assign is configured for PWM.
Some of those new options are for a gear position switch input or a weight on gear input. Fancy stuff you may not have so don’t worry about it.

I tried both of those set-ups and neither one worked. Then it dawned on me the servo rail isn’t powered internally and I need to use a BEC. Problem solved, (I hope).

Rick J Riggins
2585 E Pikes Peak Ave. # T-101
Colorado Springs, CO 80909

(719) 219-6884

Digging that out as I’m having the same problem during build of my quad. Setup is:

Pixracer Pro
Arducopter 4.1RC3 QUAD/X
Tarot TL65B43

RC8_OPTION is set to 29
SERVO7_FUNCTION is set to 29 (yes, SERVO7, not a typo)
Servo rail is powered on output 8 with a 5V BEC (as the Tarot’s have as operating voltage)
PWM values are 1100 and 1900 in MP’s Servo Output, messages RETRACT and DEPLOY are shown. However, no reaction on the Tarot.

I checked the signal pin vs ground and there is no change between deploy and retract (pin is low at around 0.06V, as the pins for CH6/CH4). Pins for motors show around 0.11V.

Anything else I can check for?



Kind of a double problem I guess:

  • I set the BRD_PWM_COUNT to 8 (I have to find that out but presume that is setting OUT 7 / 8 to PWM)
  • the current delivered by the onboard BEC of an ADP PDB360 is NOT enough! Two landing gear motors just made some sound or just one of them moved, seldom two. I removed one and the other one is consistently working as expected.