Holybro Pixhawk4

Does anybody have Fw plane 4.05 (or any other plane Fw for that matter) installed on a pixhawk4?
I am just setting it up, and got to servo outputs and i’m getting no PWM signal on any servo connect pins.
I have tried arming (I think this really only arms motors and the other servos work even when disarmed anyway) but make no difference,
I also have made sure there is 5v accoss the +,- pins of the servo header.
I can see the numbers changing in status page ch1out, ch2out etc, but no action on any connected servo.

have you connect bec circuit

I found that all the parameters for the pwm outputs, by default are set to -1 (normal range 1000 - 2000us) and this is apparently so you dont get noise from servos when not armed, but all the armed min max values etc were also populated with -1.
Ive gone to px4 now anyway and that got the fmu active and fixed the bootloader/error light being on.
Maybe these pixhawk 4’s aren’t really supported by arduplane fw.

They are supported. What you describe is not normal default settings.

Ok, well maybe i wasnt doing it right, but i tried plane 4.05 fw install through mp, and through qgc, then i tried renaming the apj (?) Firmware file to a .px4 and loading that through custom firmware option, but the results for me were always the same, ie fmu bootloader led flashing, and fmu active light never on…
Then i read on another forum that it wasnt supported and i just guessed that was the reason why it wasn’t working out for me.
I’m basically familiar with mp so tried to make it work, as id already spent alot of hours reading through the docs learning about it. But i had no success with the bootloader etc and when i put px4 on it, the fmu was active straight away.

There is a safety button for ardupilot for some reason. It won’t let the servos move unless it has been pushed. With the pixhawk 4, it is built into the gps module and is the flashing red pushbutton/led. You can also disable the button arming system with the parameter BRD_SAFETYOPTION I believe.
Hope this helps

Yes, you were correct, I have managed to get PWM output working now it was the safety button.