Holybro Pixhawk 4 & Camera Trigger

I have a maddening issue and hope someone can help. I built a large quad with the Pixhawk 4 and PM07 to power the ESCs. ESCs wires are soldered to their respective motor number on the PM. I have flown the quad several times and even tuned it. After I was confident the drone was ready for work I mounted the A6000 camera on it and have tried every parameter and port/servo I could think of. I also tried many suggestions from people with other Pixhawk controllers.
At this point the camera will trigger when I connect it to the servo pin or even when I turn the camera on while plugged in the the drone. I am using a shutter cable to servo connector. When I trigger the camera in mission planner or on the remote, an image icon appears in mission planner but the camera does not actually trigger. I have the FC connected to PM via IO out to IO in.

I read something about output groups but do not understand that. Maybe that is why I cant trigger the camera.

Please tell us what shutter cable did you use, and also a param file will be very helpful.

I used the shutter cable from a wired release button I had. Some generic brand. When I touch the ground focus and shutter pins together it triggers. Here is a parameter file. I have changed the setting so many times Im not sure what they were in this file.
PixHawk_4_031621.param (18.4 KB)

Ok I will try that. I had changed the board count to 4 and to 0 but I had always made the relay pin 50-54. What is the 101-106?

Ok I kind of get it.It made more sense on the first PixHawk. So are the IO and PWM on the same rail of the PM07?

I just have never heard or used the 101-106 so I had put it where it made since in my head. On the original PixHawk the motors were on the rail and anything else went next to that. So it had me a little confused

oh…I’am so sorry the pixhawk serials the co-processor’s output is MAIN PWM OUTPUT, the MAIN processor’s output is AUX OUTPUT, so I wa worry about this

So what are you saying? The relay pins 101-106 will not work?

I have the IO out to IO in cable connecting the PH4 to the PM. If I connect the cable from IO in to FMU out I get motors working but no camera. Now with IO out to IO in and BRD set to 4 which FMU pins do I use for the camera?

In pixhawk 4 #17 is FMU PWM OUT and It’s AUX1-AUX6, the GPIO MAP is(50-55)
The #11 is IO PWW OUT which is MAIN OUT1-OUT8(101-108)

1 Like

I get all of that except #17. lol Why did you underline that? Or do I need both cables plugged? in? That would make more sense.

I tried 55, 54, 53, and 105 on my CUAV V5 which is also based on FMUV5, only 55(aux6), 54(aux5) works, could you try this ?

Oh ok thanks. Let me try that real quick

I had to move to a different pin and that meant taking a piece off. The pin I circled should be Aux 9 (50) correct?

Yes, If you are connect the tigger to PWM9 It’s should be 50

Thank you for all the help. I was able to find and fix the issue. The cable I used was backward from the factory. Red was ground and Black was the shutter release.

For others that come across this post.
Below are the settings that worked for me. I will make a video on YouTube documenting the process for others that have similar problems. Video (when posted) can be found at GM6 Drone Mapping
Parameters as follows:
PixHawk 4 with Power Module 07

Are you sure about the BRD_PWM_COUNT,0?

This will configure all Aux ports as GPIO.

Yes I am positive. I have conducted a couple of successful mapping missions since this setup. On the power board there are 8 servo pins on the rail. Supposedly they can be used as 8 IO or FMU I think is what I read. But then I thought IO was FMU so Im not sure but the pins can be used for dual purpose. All motors are wired directly to the board so none of the pins are used for signals.