HobbyKing Micro HKPilot Mega

Can anyone help me hook up this board? HobbyKing does not offer any documentation and I want to hook up my motors and receiver. Any help would be great.

upload suceeded but verify failed exp 71 got 84 at 109938. anyone know what that means? using a ardupilot mega 2.6

What Ground Control Station (GCS) are you using with your APM2.6 and what firmware are you trying to upload?

I am using Mission planner 1.3.1 and I get the error during the firmware verify when in the initial setup screen. I believe there is a bad compass due to compass failed to initialize during the terminal portion. Also, lots of odd data during terminal portion. I also am trying to hook up my hobbyking micro apm board but I dont have any documentation. Cannot get Mission Planner to work with my 2.6 board. I have two 2.6 boards and both are giving me grief.

You might try upgrading MP to 1.3.18 to see if that helps.
Also, what version of ArduCopter are you trying to load?

I believe it is 3.2. The red led on the board blinks 2 times in succession. The board wont initialize any more and I cant arm it. Gives a different error every time it tries to verify firmware.

@LIVEONE1232003 I was able to load the latest stable version of ArduCopter 3.2.1 as well as custom built firmwares using Mission Planner 1.3.19 onto a HobbyKing Micro HKPilot Mega board. Everything loaded as per normal.

What board are you having issues with?

Try a different computer or a different usb cable or both.

I had a bad USB cable with my kit. Try a different USB cable.

Has anyone been able to make an external compass work with this board? I tried shorting the jumper they reference and I have tried leaving the jumper open. I heard rumors that you have to cut the paint on the board to cut the jumper to enable external compass. Has anyone had any luck? My GPS is working, so the compass/mag board is getting power and the GPS wiring is correct.

This board is poorly documented, with just two little slips of paper, but not as poorly documented as the PPM board I bought on Ebay, which had no documentation of any kind.

Why does Hobbyking put their name on something without proper instructions?

I searched around, found out that the trace to cut is under the paint (mask) so it is not visible. I cut it, and now the external compass works. Hobbyking and a lot of other Far Eastern vendors would be out of business if we did not have the internet and forums like this to get help on their undocumented products. :neutral_face: