HKPilot32 crash with 3.3.3

After migration from 3.2.1 version to 3.3.3 with the HKpilot32 it was a good flight for weeks. At some time during a flight the motors stopped and after this crash it is impossible to re-arming. I am looking for help to diagnosis of this type of bug.


The best to debug would be to connect it to mission planner and see the error message that is preventing you from arming. Please don’t forget to take out the propellers.


Hi Tabascoz,
Thank you for the answer. Prior to put the question on the site, I already tried to find the reason. Maybe I missed something but the only error message is Bad AHRS. By looking to the enclosed window we see that the values of the Accel’s and the gyro’s seams normal. Even the number of the satellites and the hdop found indoor, could be considered as good.
In flight,the Quad showed a strong 180° degree, tournament and stops the motors. It is for this reason that I supposed a memory phenomenon for the accel’s or gyro’s. I tried to re-upload the 3.3.3 version but the Mission Planner indicates that the version already is on the board.


If you want to reload 3.3.3 you have to load first another version i suggesr load a rover or a plane and then load the copter 3.3.3


Anything against upgrading to 3.3.4-rc1? On the screenshot i can see that your ekf monitor is red. Could you please click on it and see which sensor it is showing as red?

I would suggest that you check all compass orientation and it’s mountings. Bad AHRS usually shows mismatch data coming from the magnetometers and imu.

Hi tabascoz,
Thank you for the answer. You are right concerning the sensors. Unfortunately, slate in panic to not receiving an answer, I asked to HK the permission to send back all the set. After weeks of negotiations they accepted it. Monday morning I will send it to the post office.
Mean time, please help me with your advice for an other set. In my opinion the level of reliability for the hardware APM implementation performed by HK is at a quite low level. On an other side, the 3DR seams to be expensive and non available for moment.
Yours sincerely,

Hi cookmangr,
Thanks for the advice. I will apply it on the next version of the APM set. By the way, please let me know how to load a APM version on a CRIUS FC board. I used it for a UAVX Quad but now I would be interested to use it for the APM software. By a Brute Force procedure the soft is downloaded but finally it not works. The board seams to not being recognized.


I m sorry but i dont know the awnser for your question

But a friend of mine with also a hkpilot32 had the same problem like yours

He had several flights and from nowhere the flight controller reset the motors stop and the copter fall from 15 meters

He thinks that the problem was from power of the flight controller

So now he buy a mauch power board and he also power controller from rails