High Vibration only in X axis

I am facing high vibration in x axis. Can someone help me with this issue.
You can find the log file below.

Just stating the obvious here: balance your props, and update to ArduCopter 4.2.1

Not that it would fix an X-vibe this bad but that craft should not have left the ground on default parameters. Update to latest Stable as @amilcarlucas says and make sure EK3 is enabled. You are on EK2 now. Then use Mission Planners Initial Setup Parameters page in Mandatory hardware to set the pre-flight parameters. Then you can start tuning and troubleshooting problems.

Ok will try with 4.1 above and enable EK3.

Generally what do you think about why X axis vibration occur?

Post a photo of the craft. A flexy frame or arms, prop balance maybe. Or if you have cables pulling on the Flight Controller.


When there’s only bad vibration showing on X axis, it means there is something causing vibrations on X and Y axis (usually prop or motor balance) but the flight controller anti-vibration system (double-sided sticky foam blocks) are not all equally sized or positioned. X axis vibration damping is not as effective as Y axis vibration damping.
So there’s two problems to fix.