Servers by jDrones

Hi Power radio link


(Jader Leite) #1

Hi
Does any one has experience using a regular 5W radio Link that works at same baudrate as the 3dr radio that comes with the Kit Autopilot32 ? This is a regular data link radio that works via RS232, I am not sure if I can use a different radio to connect my boat with the computer. If some one could give me some directions I would appreciate.

If I can not, there is any way I can amplify the 100mW that comes with the Kit?

Thanks


(gmorph) #2

I don’t know what country you live in or what band the 5W radio operates in but I’d be surprised if it was legal. Most countries have a 1W limit in the 868 (Europe) or 915 (Aus and US) frequency ranges. As such you can purchase these radios
http://store.rfdesign.com.au/radio-modem-bundles/
which I have used extensively.

There wouldn’t be an easy way to amplify the 100mW radio. Better just to replace it.

Finally ArduPilot just needs a standard serial link to the radio. If your 5W radio supports that then it should work just fine.

Thanks, Grant.


(Jader Leite) #3

Hi Grant,

I am in Brasil and any Radio Link here needs license, so for 100mW or 5W is the same I need license.

I think I will follow your suggestion and use the radio you suggest, it is less expensive them a 5W radio and it is a direct connection.

Thanks for your feed back.


(Kevin Klemens) #4

@J.Leite I second Grant’s use of the RFD900 series of radios. I have an RFD900+ on my current boat and ground station, but I will probably be updating to the RFD900x on my next one. Great radios and great range. I’ve never had an issue with them connecting or holding the connection.


(gmorph) #5

Be aware that at the time of writing the RFD900+ and the RFD900x don’t talk to each other. So if you have a bunch of RFD900+'s and you wanted one more radio for a new vehicle you could either buy one more RFD900+ or 2 RFD900x so one could be used for the GCS radio. Hope that makes sense.

Thanks, Grant.


(Dimitris Liandis) #6

Hi Guys
I have built a bait boat with pixhawk 2.4.8 Chinese version with Rover firmware and purchased the RFD900+ Telemetry units.My major problem is that I loose the radio link after 300m on the water.
Does anybody know which settings are required in mission planner GC in order to succeed in long range radio link?
Thank you


(gmorph) #7

Its normally the “Tx Power” setting within the SiK firmware. By default its 20 which is 100mW however the Rfd900 can do up to 1 watt. This page has a lot of information:
http://ardupilot.org/copter/docs/common-3dr-radio-advanced-configuration-and-technical-information.html#power-levels

Using antennas with 2 or 3 db gain then you should make the setting about 28 to keep it under the 1 watt EIRP if your in Australia. You should of course read the legislation around this for yourself and make your own determination.

And this only works if your running your radio off Telem1 as the other ports don’t provide as much power as Telem1 does on a pixhawk. Keeping it at 28 or lower reduces the power required and thus the strain on Telem1.

Thanks, Grant.


(David) #8

Grant,

I never knew this. Otherwise the ports are the same? For other reasons, I am providing power to the RF900 from a 5 v BEC. Just want to make sure I am not doing anything to limit my range. Is there a radio setting that adjusts power output automatically based on RSSI? Sucks to be blasting 1w when you don’t need it.

Thanks,
Dave


(gmorph) #9

Great that your powering the RFD900 externally - that is the best way.
The ports are the same except for the power output they can deliver.
I don’t believe the transmitters auto-adjust power output but I am by no means the expert in the area.

Thanks, Grant.


(David) #10

Grant,

Thanks for the reply.

Reading the documenation I see RO and R1, TARGET_RSSI and HYSTERESIS_RSSI respectfully. Looks like setting these parameters will auto-adjust the power setting based on RSSI. Exactly what I am looking for. Now I don’t know if its appicable to both the + and the x!

I have a + and don’t see either parmeter in my remote radio.

David


(gmorph) #11

David - your on your own there. I’ve never adjust those parameters and don’t know anything about them.

Note the + and the x aren’t compatible with each other AFAIK. One won’t talk to the other.

Thanks, Grant.