Hexacopter Motors do not spin

Hello there,

My first hexacopter build with an F550 kit from China. I am able to calibrate the ESCs individually, I also was able to test spin each motor by directly running each motor one at a time direct from the RC receiver throttle channel.

When using Mission planner, I can arm and disarm the autopilot no problem but no motor turns at all. Not even after arming.

I tried the motor test in mission planner but no joy.

I can see the throttle response on the calibrate radio screen. The ESC connectors are plugged in the 1-6 channels and black lead on top. same with the RC in.

Any idea what I am doing wrong.

I’ve tried everything I could read or watch but no joy, after many hours of trying.

I’m to the point that I’ll pay someone to get this thing flying.



just a first guess: do you see the word “safety” displayed in Missionplanners HUD?

Hi There

Thank you for your reply, I am on travel at the moment, but I will check on Sunday.


Well my travel is taking longer. I’ll reply when I get back this weekend.


I tried this evening and did not see the word Safety displayed on the mission planner HUD.

What I did was turn on mission planner and plugged the flight battery on to the drone. Connected via a telemetry radio, armed with my RC transmitter after GPS was good, HUD DISARMED changed to ARMED. But I dont get any motor movement. I tried rebinding my rc recevier and checking is the radio joysticks show movement on the set up page and it did, I can see the throttle values change as the throttle moved from low to high.

I appreciate any help you have.

Follow the wiki properly dont jump the process and firstly clear the software and reupload the firmware

Follow what wiki? What process did I jump? What sw should I clear?


you never said which flightcontroller came with the kit.
I reread your initial post. You wrote " black leads on top". That would be correct for a Pixhawk, but the infamous APM 2.8 with angled connectors, needs the signal wire on top, black at the bottom. Or signal to the inside of the board, black to the outside for straight connectors.
Do the ESC/motors beep at all after powering up the copter?

I have a pixhawk autopilot. My first quad 5-6 years ago had an APM. That build went perfectly following the painless360 video series. I am tempted to see if that old APM autopilot will work, but would rather use a pixhawk since I heard all the sensors are better, esp the barometer. I am away from home again so I cant tell you about the ESC beeping but I will in the next day or two.

Count 47, The ESC and Motors do not beep when plugging in the battery.

If the ESCs do not beep at all, they do not get any input signal. So either the outputs are not configured correctly or the ESCs are connected to the wrong outputs.
The pixhawks outputs start from the right with Aux 1-6 followed by Main 1-8.
Depending on your configuration the ESCs need to be connected to AUX 1-6 or Main 1-6.
If you could post a parameter file, it would make things easier.

count47 thanks for the information. I’m away from my project so I will try to provide a picture of the esc connections to the Pixhawk this evening. I was able to run each motor from the rc receiver throttle output so I know they work. So your advice is probably in the right direction I can only think I must have done something stupid.

Use Mission Planners Motor Test for this. Post your parameter file, many times it’s a simple configuration error.

Guys I appreciate all your help.

I found one problem I had the escs plugged into the Aux Out not the Main Out ports.

I am able to do the mission planner motor test. But do have one question I would like clarification. I am using the numbering system for the motors per HEXA X. Mission Planner uses a motoring numbering system A thru F. When I do the Mission planner motor test. Hexa X motor 5 = MP Motor A, HX 1 = MP B, HX 4 = MP C and so on around the clock. Is this correct? If so each motor works in order of the MP numbering convention.

I’m gonna try to fly it this weekend but have another question. Should the Elevator stick output with the stick forward be minimum pitch values (1112), and if you move the elevator stick back, you get larger pitch values {1912}.

Also how do I post the Parameter file? Do I go to MP/config/full parameter list?

Do I take screen shots or is there a way to down the file to something I can attach to my posts for you to read?

The motor test starts with the front right-most motor and then goes around clockwise. As you noted - this is different than the numbers system used for connection to the ports on the autopilot. So - what you are seeing is correct.

What you are stating with the elevator stick to pitch values is correct. If you push stick up/forward - the aircraft will nose-down to navigate forward. Thus, the PWM will go down.

Go to MP/config/full param… there should be a button that says save to file. Post that file here - but I think you have already fixed the issue at hand.

Thank you manavhandhi17

I hope this is the correct params. This is after I connect to the Pixhawk and MP Mavlink is complete and it I believe reads the params from the Pixhawk into MP.

Hexa X Param 3-18-2022.param (16.5 KB)

1 Like

Yes that is it. Now that motor spin test has worked successfully - you should be good to continue.

Count47, manavgandhi17 and dkemxr and everyone else,

Thank you so much for your help. I successfully flew the Hexacopter to a alt if 2 meters for 30 seconds. The flight was cut short when one prop flew off, but I was very surprised with the control I had when I reduced throttle to land. It did tip over after touchdown, but no damage. Another stupid mistake by me not tightening the props.

I will order replacement parts and get back in the air next weekend.

Again thank you very much.

1 Like