Hexacopter issue

Hi all, I am new to this RC work and also apm.
I am trying to put together a hexacopter with apm 2.6 connecting with Spektrum AR8000 RX and DX8 TX.
Issue 1, When I was doing the radio calibration on mission planner the throttle and roll channel were switched. But when I run it on APM planner it works fine.
Issue 2, when I armed the copter motors are not running but after switch it to RTL mode, give it a little throttle the motors starts turning but slowly slow down and sometimes only 3 motors are turning.
Issue 3, I tried to calibrate the ESCs but nothing happened.

Please help I been trying to figure out this issues for 2 weeks.



Hi John

Not too sure about 1, but it’s not unusual to have to reverse your servo settings via your TX settings. I run a DX6 and I had to reverse my pitch when I set it up. I would stick with one programme, which would always be MP. I only use APM Planner to update my firmware as it always does it first time, otherwise I find APM Planner too limited in comparison.
In relation to item 2, it sounds like your motors are not set to spin on arm. Some ESC/Motor setups suffer from spool up issues and the motors jitter until you give them enough juice to start properly. This is why some FC’s spin on arm to avoid this. The NAZA is a prime example and spins at about 30% on arming. Personally, I don’t like them spinning upon arming, however you can alter this setting in the parameters using MOT_SPIN_ARMED settings.
In relation to 3, it’s worth reading the initial points to consider on the Ardupilot calibration page, i.e

  1. DJI Opto ESCs do not require and do not support calibration, so skip this page completely
  2. Some brands of ESC do not allow calibration and will not arm unless you adjust your radio’s throttle end- points so that the minimum throttle is around 1000 PWM. Note that if you change the end-points on your TX you must re-do the Radio Calibration.
  3. Begin this procedure only after you have completed the “Calibrate radio control” section of the Configuring Hardware page and “Connect ESCs and motors” part of the Assembly Instructions. "

Not sure what ESC’s you have but if all else fails, you may have to calibrate your esc’s manually one by one, directly plugging them into your RX or with a made up 4 way servo harness to do them all at once.

Bear in mind though John that you need to sort items 1 & 2 first before proceeding onto the motor calibration. Good Luck!