Hexa Crash During Loiter Test

Hello all,

I am working on a hexacopter (Tarot 680 Pro frame, 13" props) for a project and experienced a crash recently. I’m running ArduCopter (4.2.1) on a CubeOrange powered using a 6S LiPo. I’ve had many short, successful flights and have completed the tuning process up to autotune; I still have to do autotune and other advanced tunings. I was testing loiter today when my drone crashed. At first loiter wouldn’t engage (buzzer made two beeps), but after a short while, loiter engaged successfully. While running loiter it suddenly descended and crashed. I would appreciate any help in resolving this before I fly again.
Data Log: https://drive.google.com/file/d/1oM87cgF1t-cLW_6Ec2LjQns6ohkbVPhb/view?usp=sharing

Possible GPS glitching? I’ve had similar Loiter issues during a poor GPS environment,
caused by a partial foliage canopy. Your auto analysis does show GPS glitch errors.
Might be something for the heavies to analyze, but it’s happened here…an actual flyaway a few years back.

1 Like

The first failure to engage Loiter Mode was due to the fact you took off before your autopilot have consolidated a position for your drone. In order to avoid it on future, enable the cylindrical fence around drone, it is always a good measure against fly-aways and it will trigger you a pre-arm check until position is consolidated by ardupilot.

The crash itself was probably caused by Motor 3 failure. You have a saturation of Motor 3 when you start to lose height:

Double-check your wiring and try to find out why Motor 3 lost thrust in mid-flight.

1 Like

I advise setting FENCE_ENABLE so you cant arm and take off before there is a good 3D Fix - this will avoid many GPS issues, even though your GPS seems to be working reasonably once it is allowed time to acquire a proper fix.

You real issue is the battery voltage, and the aircraft goes into Land mode (too late)

Current measurement is not correct so I cant tell what’s going on there. The voltage issue could be caused by a bad battery or it wasnt properly charged to begin with.
You need to connect to Mission Planner and go to initial params, put in your prop size and battery cells, accept everything it offers including (especially) the optional battery failsafe settings.

If for some reason you cant arm or flights are unusually short (battery failsafe) DO NOT change the settings that were calculated - best to find out what is wrong with your battery or voltage/current sensing.

As Bruno said, a motor failure could cause the voltage drop, hard to tell without proper current measurements. If you look at this graph the motor outputs dont saturate until after the voltage drops, which is to be expected with a poor battery.


Yes, would agree with what the guys are saying. When your battery got down to ~18V (way too low) it wasn’t supplying sufficient current and the output commands started to ramp up until there was insufficient thrust to stabilize the craft. Switching to Land Mode was not the greatest idea; getting it to the ground as quickly as possible in Stabilize might have worked but I’m sure it was all happening fast.


Thank you all for the help. I will look into all of the suggestions and provide an update when finished. Before I start implementing these changes, should I flash my CubeOrange to ArduCopter 4.2.2? It’s currently on 4.2.1.

Which kind of ESCs are you using. Some have low voltage protection. Maybe the ESCs of the named motors switched off because of low voltage.



I’m using the Hobbywing FLYFUN 40A V5 ESCs.

Yes, it is always highly recommended to update to the latest version.

This ESC has cut off voltage. Maybe that was the reason for the motor loss.

1 Like

After reading over the suggestions in this thread, I believe the cause of the crash was simply the battery being too low. When I charged the battery a few days after the crash, the voltage of the battery was about 18 or 19 volts. This is much too low for my hexacopter. As recommended, I’ve redone the initial parameters and made sure to enable the battery failsafe this time. I’ve done the tuning steps leading up to AutoTune, and now I’m just waiting for a day with favorable wind conditions. Thank you to all those who provided help in this thread, especially @BrunoBagarini, @xfacta, and @dkemxr.

1 Like