Servers by jDrones

Hex Here+ rtk - burned out


(Nikolay ) #1

I bought HEX Here + RTK a year ago, since then I tried to set it up, but I never managed to do it. I have never received a Fix or Float solution, all the time a 3D fix. I read many setup instructions and came to the conclusion that I need to change the firmware.
I am building a project with Pixhawk on a large agricultural tractor, so as not to remove the device from the tractor, I decided to connect the gps antenna to the bluetooth module and update the utility through the UART bus. The Bluetooth module is powered through 5V, but it looks like the RX / TX GPS line was not designed for such a load. The GPS module has stopped working, the led does not shine, but on the board there is a PPS led it blinks. I also get data on the UART bus, but this is some kind of a mess of characters. Obviously something burned out.
We tried to find a datasheet or a device schema, but this seems to be secret information. In this topic Here+ RTK USB connection Proficnc laid out a piece of the scheme
we are looking for the full version, we want to make repairs ourselves, because we live very far away - in Ukraine.
Maybe someone has already been engaged in the repair of these modules, thanks for any help.
Sorry for my English.


(proficnc) #2

The LEDs are on I2C, so they shouldn’t work with your Bluetooth module
Check the baudrate of the GPS and your Bluetooth module, they need up match


(Nikolay ) #3

Thanks for the reply, I hope for your help.
Unfortunately at all boutrate the module does not work correctly.


In the u-center, I can connect but the terminal is empty, mon / ver is also empty.
I bought 2 cheap modules to repeat the experiment. I plugged in a cheap module and it burned out too. I did this in order to determine whether the Ublox chip is failing. Using a multimeter, I determined the part that burned it was smd lg33, after replacing the cheap module began to work as new.
So, I think a similar problem on the Here + module.
The problem is that the components are so small that I cannot recognize them. The part signed as U1 R33 looks like a voltage regulator, what is this component?
thanks for any help


(proficnc) #4

What makes you think it’s burning out, and why are you burning them out? What are you doing to these poor devices?


(Nikolay ) #5

I’m afraid I can not explain because my English is not very good. Devices burned due to connection errors. Now it no longer burn.
I connected the gps module to the flight controller and it does not work. The leds do not blink.

Can I get rtk fix If I use here + base with cheap gps not from Here + kit
Should it work?