Hex Blue Cube Does not Connect to Computer, Amber Light, No COM Port

I was calibrating the compass on a Hex Blue Cube and HERE+ GNSS receiver when I noticed the side LEDs on the HERE+ were no longer on and the telemetry radio was no longer connecting to Mission Planner. I powered off the Blue Cube and plugged it into the computer via a USB. The lights on the Blue Cube turned a solid amber and the LEDs on the HERE+ flashed for a second then stayed dark, but the safety switch continued to blink (video below). The Blue Cube also did not show up in the computer’s COM ports and will not connect to Mission Planner. I have been able to connect the Blue Cube to this computer before and this was the first time I have not been able to connect it. I tried to power the Blue cube up while holding the safety switch, but this only temporarily changes the light colors and the device still does not show up in the computers COM ports (in same video). I formatted the SD card to see if that was the issue, but it caused no change. I also tried uninstalling and reinstalling Mission Planner, along with replacing the UAV drivers associated with Mission Planner. I have also tried powering on the Blue Cube without the GNSS receiver plugged in. None of these attempts have fixed the problem. Is there any suggestions on how to fix this issue?