Herelink radio calibration issue

I have calibrated from the drop down menu, calibrated from within QGC, and within Mission Planner. In PosHold mode, when I take off, the drone will not hold its position without some upward throttle. Otherwise, the drone decreases altitude. It seems the remote is not calibrated for center stick. I cant let go of the sticks and the drone hover.

1 Like

Have you got the MOT_HOVER_LEARN parameter set to 2?

I seem to be having the same problem. Unable to get a steady hover in Alt-hold or Stabilize mode. However I used the “takeoff” button, which is guided mode, on QGC and it ascended to 30 ft and hovered perfectly. When switched from Guided to Alt-hold it immediately dropped throttle to “arm” thrust and crashed. As long as I apply some throttle it is able to stay up but as soon as I center the left stick it drops no matter what mode.

I’m attempting to follow the “first flight” section of the documentation but without a stable hover I cannot proceed.

MOT_THST_EXPO is set to 0.65, which I didn’t set
MOT_THST_HOVER is 0.6875, was set to 0.5 until reading the section below.

Unfortunately weather is not cooperating today so I can’t see if that made a difference, but on the bench with props off I can see that there’s no increase in motor RPM when changing to alt-hold mode like there clearly is in guided.

Have you internally calibrated the joysticks on the Herelink !? I ask because I struggled some with the calibration on a new unit today.

I did, and did again just now to be sure. On both the transmitter (using the pull-down settings) and Pixhawk/Q Ground Control. While there I noted that I have Throttle Center Zero checked, because the first time takeoff I couldn’t get it to land with that unchecked. Just now without props I armed and “took off” and it seemed to act like it was holding enough throttle to stay airborne, but again it didn’t seem like it would “land.”

Weather is looking good tomorrow and I’ll have a little time to experiment.

Just to update, with Throttle Center Zero unchecked got a throttle warning when arming, which is OK. Armed with the throttle pushed hard down, when I let it center it shot up at an alarming rate (in loiter mode, which was quite docile before), with a clear aft drift that I couldn’t null out. I’m going to chalk up the drift to mis-calibrated sticks. Tried RTL but I think it was overridden by stick inputs. Tried to manually bring it back home but it ended up in a tree about a quarter mile away. Amazingly only damage was a landing strut and props.

I guess I’m still a little confused as to what setting to use for throttle, center zero or not. My mental map is from the 3DR Solo, where you press and hold the FLY button to arm, the motors spin at idle, then hold the FLY button again to take off and hover at center stick throttle.

Sorry to hijack the thread.

I think there is a clear error while doing the configuration and calibration of the sticks. The workflow within Herelink is kind of complicated compared to simple RCs and one needs to exactly follow the (good) documentation. If something is changed the user needs to start again at least with RC calibration within Arducopter.

To test new settings I would always remove the props and do a dry test what the motors are doing when you arm, when you change stick input, flight mode and vehicle attitude.

I think most of the users learn it this way, first have a nice crash and then implement more rigid precautions. Maybe it would be cool to have a blog with ones most spectacular crashs, its interesting to read and might help users too.


Just wondering what you did to get this working? I am having the same problem. I can’t get it to hold in loiter or alt hold with my hands off the controls. I need to input a bit of throttle to keep it at a stable hover.

I also tried auto takeoff and it worked perfectly. Rock solid 3 meter hover, switched to loiter and it dropped.

I am going to disconnect Herelink and try with my Taranis to see if I can get it to hover.

I tried calibrating and recalibrating and then recalibrating again with no luck, always the same issue with hovering.

IIRC, This was a specific problem with the Herelink losing the joystick calibration after a software update. I was confused about the process. Remember you have to calibrate on Herelink, then calibrate on the Pixhawk. When that’s done you can see if it will stay stable in Loiter mode with no stick input. Then start the tuning process in the Ardupilot documentation.

Hi, I did that a few times. Calibrated in the drop down menu from the home screen, calibrated in QGCS, calibrated in mission planner. Still no luck.

You just recalibrated and you were fine?

Yes, after recalibrating the sticks as above it was stable. I’m no expert when it comes to tuning so I’d recommend you post in a more general area and ask for help there.