Herelink : QGC status : Waiting for vehicle connection

Hello, I’m using herelink, cube orange, here3 gps, and here+ RTK. Previously all worked fine. now i have problem Qgc App can’t connect with my drone, :

  1. QGC status : Waiting for vehicle connection
  2. AirUnit LED1 Off, LED2 Yellow
  3. Herelink Radio status : Paired and data connected
  4. Remote can control the drone (sbus)

Steps that have been taken

  1. Reinstall firmware:
    Herelink Remote, (FRU01200409)
    Air Unit, (AAU01210729)
    Pixhawk (4.0.7 and 4.1.0 all tried)
  2. reset to default parameters, no use GPS & RTK
  3. Repairing Remote and Air Unit

Until now QGC can’t connect , Anyone help me please


Have you checked if Telemetry is configured correctly on Flight Controller and that connection is OK ?
In this case I would test with a FTDI - USB to serial converter connected from the PC to the FC and confirming that MavLink is ok looking at Mission Planner.

Hello ppoirier,

Thanks for your response. I really appreciate you.

ss serial parameter

I’ve set the serial parameters like the image. I think it’s ok.
There is something else i have to do?

I generally set protocol to mavlink 2 for herelink communication and the speed is autodetect up to 115 kbps but I had an issue once with speed synchronization with the air unit and I had to reduce to 57 kbps

1 Like

I don’t know the details of the issues came from. But what I did was re-install the firmware of all devices like when I first bought the herelink and cube packages.
I’ll note your solution when I’m facing the issue again.
thank you @ppoirier :+1:

1 Like