Herelink - 'No RC Receiver' after radio loss, regained telemetry


I had a problem where the radio failsafe was entered but never regained, while telemetry came back online.
During pre-flight setup we tested the failsafe twice by just shutting down the Herelink ground unit. For both tests the telemetry came back online after turning the Herelink on again, but for the second test the RC control would not come back. It was still possible to give commands from MissionPlanner without any problem, but the plane would not take any stick inputs and still show the ‘No RC receiver’ message.
We then decided to fly the plane in an auto mission to test the range, such that it would come back and land on its own if necessary. We lost telemetry and RC control a few times from 1.5[km] on, but had in general quick reconnection on the telemetry screen. Yet, once the RC control had been lost for the first time, the ‘No RC receiver’ message stayed up, and upon return (good connection on telemetry, flyby at 20[m] line of sight) it would still not clear and allow stick control by the pilot.
We then (while still in the air) aborted the auto mission just before landing and set it into loiter and RTL (to try to troubleshoot and deploy flaps) with MissionPlanner, which worked fine. Then we set up a new land mission and let the plane autoland.
Does anyone know what went wrong here?

My setup is:
Airframe: Custom 3m wingspan, standard airplane with flaps and full flying elevators

Cube Orange

Log file:
Flight log Google Drive Link

Parameter file:
params_2023_05_03_v11.param (18.1 KB)

Arduplane v 4.3.5

Herelink (on 600mW power)

Looking forward to any input!