Here3 GPS no fix in Mission Planner, but UAVCAN inspector shows Coordinates

I am using a Here3 GPS with a Cube Purple Autopilot on the mini carrier board running ArduRover 4.2.0. I had no issues getting a GPS fix initially, but since last week I cannot get a fix. I did some digging, and using the UAVCAN inspector feature in Mission Planner, I am able to see correct Coordinates, as well as it is connected to 7 satellites (see Screenshot below). I have reset the GPS, upgraded it’s firmware, checked all the wiring, and nothing has worked. Any help would be appreciated.

I guess you failed to set GPS_TYPE and the other config as per Here3 user guide?

Any other suggestions? I have the same symptoms with Cube Orange running on Copter 4.2. Im sure i followed the here3 guide properly. I can share the parameters file.

I only changed GPS_auto_config to 1 instead of 2 and it started to work

here3 can port gps_type 9

A solution that worked for me was to reinstall ardurover onto the autopilot.